Copying styles to new Chrome profile

I'm having a bit of a problem here. I created a new Chrome profile. I copied the file in the database folder (fjnbnpb...{ of my original profile over to the new profile. I deleted the existing db file and renamed the new one according to what had been there (it was 39, and I renamed it to 3). I have verified the locations of both profiles using about:version.

But still no changes occur to my Stylish database.

I've done this before, when I was working with virtual machines. But now it's not working. Has something changed? I'm on Linux.



  • I deleted the existing db file

    renamed the new one

    still no changes occur to my Stylish database.

    I think the only possible explanation is that the actually used directory is different

  • edited October 2015 Chrome
    From about:version, here is the source location:

    From there I went to the /databases/chrome-extension_fjnbnpbmkenffdnngjfgmeleoegfcffe_0 subfolder, where resides "39".

    From about:version, here is the destination location:
    /home/paul/.config/slimjet/Profile 3

    From there everything is the same, but the db file is named "3". I deleted 3, copied 39 over and renamed it to 3, and reopened the browser to Profile 3. The new styles are not picked up, and one old test one still exists.

    It doesn't make sense to me that both files are 152.6kb. I have a few dozen styles. 39 should be much larger than 3. Something is not adding up.
  • And all the styles are there if you switch to the old profile?

  • Yes, they haven't changed.
  • edited October 2015 Chrome

    Maybe Chrome still runs when you swap the db files? It may happen if you enabled [x] Continue running background apps when Google Chrome is closed option. Try exiting Chrome via its "Exit" menu item (Ctrl-Shift-Q here) or even uncheck the option prior to exiting.

  • Ah, my friend. You are a genius. I unchecked that option, and also closed all Chrome (actually Slimjet) instances. I redid the file copy to be sure, and it worked perfectly. My copying before was always between two different machines, or to a virtual machine. This is the first intra-machine copy, and there must have been a lock on the file.

    Thanks much!
Sign In or Register to comment.