Superb

About: Wikipedia 1911 (rotane) Good rating
Really elegant and readable. Great job.

I have two requests. First, could the hover area for the navigation pane be reduced? I'm tripping it inadvertently.
Second, li items are coming through in a larger emphasized font. The main font should apply to them I think.
Blessings.

Comments

  • Hello!

    Thanks for leaving a reply! Regarding your questions...

    1: I've reduced the hover area slightly, but only slightly, because to me it is just about the right size. But i can understand that it might still be too big for some people. You can modify it quite easily yourself though:

    Bring up the style and look for this bit of code:
    #mw-navigation #mw-panel
    (It's right under /* left nav */ at around line 130.)

    Then change
    left: -255px !important;
    to something like
    left: -285px !important;
    (This makes the area 30px less wide.)

    And you're set. (Beware though that any future (auto-)update might overwrite your mod.)

    2: Blimey, i hadn't even noticed! Thanks for the heads-up, i've just uploaded a new version. :)
  • Thanks! I installed that and made an adjustment where you specified, and it's working great.

    My main browser is opera, and I'm using this CSS in Stylish in it. But one problem I'm having is using this CSS in Stylish in Slimjet, which is a Chrome derivative. I'm going to attach a shot of a wikipedia article, which shows that the disappearing menus are not working.


    943 x 841 - 251K
  • Well, that looks pretty messed up. I've tried the style in Chrome and Safari (both of which use the same rendering engine – Webkit), and they're all fine. I have no idea why Slimjet would not render the page the same way. (But i must admit that i'm not familiar with Slimjet; i haven't even heard of it until today.)

    Unless maybe you're logged into a Wikipedia account and have a different skin or custom CSS installed? Check this by going to this page: https://en.wikipedia.org/wiki/Special:Preferences#mw-prefsection-rendering . Under Skin select "Vector (default)". That's the only thing i can think of right now.
  • Wow, thanks. I set it to Vector and the problem immediately resolved! Really appreciate your help.

    Slimjet is a very impressive Chrome-based browser, from the folks who do the impressive Slimbrowser.

    Also, one thing I added to the CSS when I was trying to reduce the hover zone was transition-delay. But with the reduced zone it's not necessary for me any longer.

    Thanks again!
Sign In or Register to comment.