Stylish for Safari

124

Comments

  • Latest version, 1.5, still suffers from same problem.
  • DMC, are you using other extension which can break/block Stylish functionality? Try to disable others for a moment.
  • Let's see :)
  • Nope, disabled other extensions and updated stylish - no dice. My own mods for Facebook gets partially applied, but Fullscreen Mod does just move FB logo and other stuff in the blue bar a little to the left and actually manages to make the center column even narrower than it's without style applied :D
  • Making a comparison now in BBEdit to see the diffs there are.
  • 1.5.3beta works :)
  • I'm pretty happy with how this works now, so I'm about to make it the suggested choice for Safari users. If we could get a few more people to try it out that'd be great.
  • I'm pretty happy with how this works now, so I'm about to make it the suggested choice for Safari users. If we could get a few more people to try it out that'd be great.
    LOL! I love the Office Space reference, Jason! image
    Glad to see the Safari folks getting a bit of love. :)

  • Well well. Using the following snippet on facebook:
    /* Hides group pinned posts until mouse over (kk 14Apr14 SnipDev) v3 */
    .groupJumpLayout div#pagelet_pinned_posts ._4-u2 {
    max-height: 40px !important;
    overflow: hidden !important;
    -webkit-transition-property: max-height;
    -webkit-transition-duration: 4s;
    -webkit-transition-timing-function: linear;
    -webkit-transition-delay: 3s;

    transition-property: max-height;
    transition-duration: 4s;
    transition-timing-function: linear;
    transition-delay: 0.3s;
    }
    .groupJumpLayout div#pagelet_pinned_posts:hover ._4-u2 {
    max-height: 5000px !important;
    }

    No transition effect. With Firefox the effect is there, also on safari when css is applied with social fixer extension.
  • Looks like this is a webkit/style related issue, not a extension bug.
    Did you see your style in DOM (header section, css link with apple character in id)?
  • I've made changes to link to http://sobolev.us/stylish/ for users who have Safari but don't have the extension as well as recording installs from Safari in the install counts. When I use 1.5.8 however, the install button on styles isn't working any more. Not sure if it was a result of one of my changes or something else.
  • edited April 2014
    Jason, can you please update last one link in head section of your site with httpS link?
    This one - <link rel="stylish-id-url"...
    v 1.5.9 updated with a fix for parsing both types of links (http|s)
  • Which link are you referring to?
  • Jason: link tag with rel = stylish-id-url
  • That URL is used as an identifier only, and to maintain compatibility with previous installed styles, it will remain http.
  • Ok, anyway, issue fixed.
  • Hello guys! Feel free to check latest version 1.8.7 with persistent storage for your styles. No need to worry about clear history issue any more! Import/Export settings option still available anyway. + Retina ready.
  • Hmph... Works and doesn't, on and off. I need to disable style and then refresh the page, then reapply the style to get it to work. I'm using this almost exclusively to restyle Facebook, and now my styles wont show in the popup, not even if they're global styles. (Safari 10.0 (11602.1.50.0.5))
  • @DMCrimson Can you please provide style id/link for test?
  • They're custom ones, as I've edited them to my liking and prevented updating... but just a moment ago, the button provided a list of styles that i could toggle on/off - apparently swearing was the key :D

    groups fix:
    (URL Prefix: https://www.facebook.com/groups/)

    style:
    div#contentCol._5r-_.groupJumpLayout.groupLitestandClassicJumpLayout.homeWiderContent.homeFixedLayout._1qkq._1ql0 > div#content_container.clearfix {
    padding-left: 35px !important;
    }

    div#contentCol._5r-_.groupJumpLayout.groupLitestandClassicJumpLayout.homeWiderContent.homeFixedLayout._1qkq._1ql0 {
    min-width: 976px !important;
    width: calc(100% - 245px) !important;
    padding-right: 20px !important;
    }
    div#contentArea._14i5._1qkq._1qkx { padding-left: 270px !important; }
    /*
    div#content_container.clearfix > div#rightCol._14iw._1qkq._1qku {
    position: relative !important;
    left: 1100px !important;
    } */

    span._51lp._51lr._1o_3 {color: red !important; font-weight: bold !important;
    border: none !important;
    }


    This moves group content to the right and widens the area. But this led me having to use z-index for leftCol to make them links clickable...
  • Sorry, but this style doesn't work for me in any Safari version (old and new one), no any visual changes in my case. Maybe you related on very specific class names or something?
  • that's for group-pages, but I think the style was hacked to remedy errors caused by https://userstyles.org/styles/90546/facebook-full-screen
    (the content moved way to the left over leftCol)
  • edited August 2016 Safari
  • They're used in conjunction :D Here's what my FB-groups look like with just that 90546 used:
  • And to make matters worse, they don't work all the time... Sometimes the style is not applied as I said.
  • edited August 2016 Firefox
    This one has 90546 plus that snippet applied, along with this as separate style:
    /* Color group post counts */
    ._2jgb, ._1o_3 {color: red !important; font-weight: bold !important;
    border: none !important;
    }
    /* Hide rightCol */
    div._5rzs._5v6d {
    display: none !important;
    }

    div#leftCol {
    z-index: 10 !important;
    }

    Hiding rightCol is crude, but it messes the content area badly unless hidden... Could be wider also. And despite these snippets posted, this is not intended to be debug-css :D I just wonder what's going on with Safari 10 (I think it's developer preview 7) not showing styles in dropdown earlier, and only just now...
  • You can try to download version 1.9.2 from website ( http://sobolev.us/stylish ) where i have changed style location
  • I have it already installed :) Forgot to say that.
  • The main bugger now is that I have a style that applies to URL Prefix (https://www.facebook.com/groups/) and sometimes while browsing the groups, the style doesn't show up or get applied. When that happens, I need to open management tab, disable and enable the style to get it applied. Any way to log this?
Sign In or Register to comment.