Stylish Custom²

1151618202167

Comments

  • edited December 2013
    AWESOME! Works! Thanks a lot, Sonny!
    Personally, i don't see anything wrong with it any more, everything seems to work as it should as far as my use.
    If you get bored, maybe you can look at the first page requests list and tell the guys if you'll do any of those? They've been waiting for 2 months now.
    I'm not sure about #8. I mean, it makes sense to have it but on the other hand, what are the default settings? I didn't know there were defaults, just what Cho was using, i guess? I suppose if you set it to whatever you think is reasonable w/out breaking stuff, could be default prefs and maybe you could add a button for restoring defaults right next to the Import button? Might be helpful for testing but i don't know how much trouble this is comparably to how useful it is. I mean ... what can go wrong with SC settings after all?
    Anyway, just saying, i personally don't need any of those.

    Again, great job and THANKS a LOT!
    image
  • I think a default settings button would not be a good idea IMHO. Due to the number of prefs, it would take an average user too much time to go thru all of them if they did not happen to save what they had already set up. To reset, they would need to right-click on the pref extensions.stylish.custom.???? in the about:config, they wish to reset to default, and hit the R keyboard key (will reset to default setting).
  • edited December 2013
    Updated: Stylish Custom Mod 9 v1.4.2 https://dl.dropboxusercontent.com/u/77691265/XSCMod9.xpi
    Added the customized error box as an option (themed or default) into the Options dialog in the Custom Themes section under the General tab.
  • edited December 2013
    Thanks! It's not clear what it means though. Maybe you should label it as 'Custom error box' 'cause as it's now, it seems you have a choice to show the error box or not ... which will make many to scratch their heads (why would anybody want to hide errors?!).
    But i came to say that the scratchpad doesn't seem to remember the last state in the nightly (latest, 28a1).
    I also noticed that it will always be closed after updates and i have to open it, close the editor and the next time i open it, it will stay open.

    EDIT: maybe not needed (change the label) 'cause it is under 'Custom Theme'.
  • No, installed the latest update in the main profile (26b10) and the scratchpad is always closed. Have to open it manually, every time i open editor.
  • edited December 2013
    Checking on Scratchpad.
  • edited December 2013
    @makondo,
    Scratchpad fixed.
  • Updated: https://dl.dropboxusercontent.com/u/77691265/XSCMod9.xpi
    Added textbox to set height of scratchpad grippy and option to save scratchpad text in the Options dialog under the Text tab.
  • edited December 2013
    ... option to save scratchpad text...
    image are you kiddin' me?! Awesome!! Thank you very much! I like that it now remembers text. I had this numerous times when i close a style with some stuff in the pad that i need in another style and it's gone. If i copy something i can recover it from my clipboard but i often just drag/drop bits in there and they're gone when the editor is closed. This new option will help a whole lot!
    But i think you need to put something there, like 100px or 120px or whatever is reasonable to you and let people change it by example if they need it 'cause some people might not know how to put the pad size (like 120px?), OTOH, people who install SC should be able to figure this one out. I still think it needs a default number other than 0.
    One problem though, it doesn't remember what i put there and the next time i open Options, it's back to 0 again and the scratchpad is closed.
    The grippy size is good ... probably. I don't know, i use an image which i use for all grippies in Fx but i would imagine it's really nice to be able to set its height.
    I'm going to uninstall it and reinstall clean, 'll see what happens.

  • edited December 2013
    Try a restart after changing options. Works here, but will add pref for scratchpad height for a default setting of 64.
  • Updated: https://dl.dropboxusercontent.com/u/77691265/XSCMod9.xpi
    Fixed bug with having to click grippy twice, when openning editor with scratchpad opened.
  • The same, scratchpad set to 0 and is closed.
  • edited December 2013
    Try my last update I just uploaded a couple of minutes ago and then restart after openning editor for prefs to kick in.
    Edit:
    After setting scratchpad height in Options, are you clicking on the save button next to it?
  • The size works but it's always closed. I always leave it open 'cause i use it a lot but every time i open editor, it will be closed.
  • edited December 2013
    There's also something funny now. The cursor disappears and flickers when pointed at the grippy if i set it to anything smaller than 6px (which is in my style anyway), like 4px.
    Also, i reset scratchpad to 120px, saved, closed the editor, opened it again ... the scratchpad is like 10-12px high and when i opened Options from the editor ... both boxes had 0 in them.
    Yes, i did restart Fx. I did the above twice with the same result every time: scratchpad closed, both values show 0.
  • edited December 2013
    Took care of the cursor for the grippy. Both the input boxes in the pic get their values from the prefs on openning of the Options dialog (extensions.stylish.custom.scratchpadheight and extensions.stylish.custom.grippyheight). What are the values for those prefs in your about:config?
    Edit:
    Are you entering and integer with the px (i.e. 24px)? Only takes an integer.
    Updated to remove characters other than integers.

    image
    522 x 88 - 7K
  • Uuuh, that explains it! Now, if only the scratchpad would remember its last state....
  • edited December 2013
    Try a restart. Works perfectly here.
    Let me know. I can try other methods.
  • I did, i restarted a few time already. I uninstalled and reinstalled. Nothing works (26b10). It's always closed. Worked before though, v.8?
  • Oh wow ... hehe ... it still doesn't work but now it also covers the whole code textbox and bottom toolbar.
  • In your about:config, what is the value for extensions.stylish.custom.scratchpadheight ?
    If it is not what you set in the Options, manually insert the value for it (integer only).
  • It matches what i have in the Options:

    image
    575 x 106 - 28K
  • I experienced that earlier. Trying to duplicate.
  • Hold on, i'm testing other profiles. Looks like i don't see this in at lest another one, a nightly.
    Thought it could be a style but i see the same with all styles turned off. Something in about:config? Will have to uninstall, clear all settings, reinstall.
    Working on it.
  • OK, it has to do with the SP height.
    Here's what i did and saw the same in 3 profiles, one beta and 2 nightlies, i install from the link above, v9.
    I check the pad, it looks all right. In one profile i imported settings with the height set to 120, closed the editor, reopened it and SP covers the whole codebox.
    In another profile, i didn't import settings and it looked all right. I then set settings to 50 and it broke. So, the size doesn't matter! (i always knew that!). Any change in that option breaks the SP.
    BTW, this is when i thought having Restore default settings would've been helpful - i wanted to reset and try again but had to go to another profile instead.
    Anyway, i don't know why it works for you and doesn't for me. Remember, it's not my settings 'cause in one profile i didn't change anything except the height of the SP.
  • Try this one. Minor changes to method: https://dl.dropboxusercontent.com/u/77691265/XSCMod9.xpi
    Got rid of the save buttons for those two input boxes. Inserts scratchpad height and grippy height on entering the value into the input box.
  • edited December 2013
    Nope, the same. If i set the height to 0, it opens all right, about 50px high? or something like that. If i set it to 1, it opens with the same size. If i set it to 10, it opens double the size, if i set it to 20, it grows again and so does 30, 40, etc. eventually it covers the whole codebox depending on your editor size (if it's small enough, 20 will cover it too). Something about the input units.
  • Checking.
  • edited December 2013
    OK, try this: https://dl.dropboxusercontent.com/u/77691265/XSCMod9.xpi
    Converted integer type to string type, which means, the height entries need the px, pt, em, etc... (i.e. 100px). Seems like your entries were getting translated as percentages.
Sign In or Register to comment.