Thunderbird 60

Extension options doesn't work in Thunderbird 60 beta. Empty page. No way to install styles.


  • edited June 2018 Firefox

    Maybe use old userChrome.css / userContent.css - should still works.


    You can try use old XUL version and CompatybilityMode: extensions.strictCompatibility

    If these workarounds do not interest you then you have to wait for the Thunderbird 60 add-on support enlargement or repair advice to be something else than bypassing the problem.

  • 2.1.1 doesn't seem to work either. UserStyles doesn't detect Thunderbird and there is no way to get into options to install style manually.
  • edited June 2018 Firefox
    userChrome.css in Thunderbird works.
    It's under Profiles. The Trick everyone seems to miss is file properties.
    Read-only should be set for the css before running Thunderbird (using the latest v60+).
    path: C:\Users\user\AppData\Roaming\Thunderbird\Profiles\profile\chrome\userChrome.css
    @namespace url(; * {color: rgb/hex/name !important; background-color: rgb/hex/name !important;}

    Ctrl+Shift+i will open the Developer Tools.
    After allowing it to run1, you can view the DOM elements and include each one specifically by Class, attribute, ID or path , if you don't really want the * selector.

    1. image

    Also, if anyone found a way of coloring the column headers, i would be so happy.
    Still haven't found what property is it or if it's using windows' shell.
  • edited June 2018 Firefox

    You can try downloading my add-on for Thunderbird at coded for Thunderbird 52.8.0 I don't like coding for beta versions (too many changes) and wait for the official releases.
    Various tweaks and optional Dark Theme from Add-on Manager Option button in category Thunderbird Tweaks or the add-ons toolbar button (see below thread for pic).
    Also adds id's, versions and date updated info to Add-on Manager category items.
  • edited June 2018 Firefox
    Thunderbird Tweaks toolbar button and Options dialog coded for Thunderbird 52.8.0
    370 x 462 - 27K
  • edited June 2018 Firefox
    Aye, i downgraded my version and this works finely. Thanks man.
    Keep it up.

    Ps. how do i stop it from resetting on load?
  • edited June 2018 Firefox
    What is resetting on load? Need more detailed info.
  • edited June 2018 Firefox
    The change of coloring, it turns to default(white) every time i run thunderbird(v52.8.0 32-bit).
    No Theme enabled.
    No other extensions enabled.
    I need to click again on every option to re-activate everything.

    If you need any file properties info, settings or anything specific, ask away, i really like your extension and need it to work.

    I actually see that i have a different(based on TB) version of your extension, since it is 53.6.2. Does that matter?
    (I downloaded the latest stable TB.)
  • The checkboxes in the Options dialog, opened by the Thunderbird Tewaker add-on toolbar button, do not stay checked? On reload, the checkboxes in the dialog are all unchecked?
  • edited June 2018 Firefox
    The options stay as i chose, the effect just isn't there until i re-activate them.
    Image and video hosting by TinyPic
  • edited June 2018 Firefox
    Try disabling your userChrome.css file. Can disable by renaming the file like XuserChrome.css and restart Thunderbird to see if problem lies in there. If not, rename file back to userChrome.css and we'll go from there. The Thunderbird Tweaker add-on version number has no correlation to TB version.
  • edited June 2018 Firefox
    Already did it.
    Should i assume that the folder chrome which is read-only, is at fault?
    (obviously in the settings of the tweaker, i chose the right profile)
  • edited June 2018 Firefox
    The file properties of the userChrome.css file should have the Read only and Hidden checkboxes both unchecked. Give that a try and see what happens.
    The profile options in the settings only display, on the toolbar, what profile you are using and not a selection of a profile.
  • edited June 2018 Firefox
    Thanks for your time, i have a problem with powershell messing around with forced read-only file properties and as i understood, i could fix it when i fix my files' attributes.
    Thanks/grazie again.
  • Prego!
  • edited June 2018 Firefox
    Added a patch to Thunderbird Tweaks add-on to correct the issue you were having. Download/Install patched version 53.6.7 from my site at
    There are also several buttons added to your Customize Toolbar Palette you may find useful as well. Just drag them onto a toolbar.
  • edited June 2018 Firefox
    Will do, thanks.
    I had to edit your js for it, now it'll be by you, the creator which is perfect.
    edit: and it works Finely. Grazie again!
Sign In or Register to comment.