Installed/Newly Made Styles Deleting themselves

edited April 2018 in Stylish Chrome

Installing/making brand new styles for this website seems to automatically delete themselves:
I have no clue what's happening. The new styles that have been made redirect to:
and then refreshing the page displays the CSS of the next style below on my installed styles list while the url is still the address I posted above. A newly installed style for the website appears on the list of my installed styles if I have that page already open but clicking on it does the same thing I previously mentioned.

I've installed and made new styles for other websites after trying for autohotkey just to test things and it works for other websites.

Styles I tried for Autohotkey:

EDIT: this is interesting. I tried making a style for Chrome Web Store and it did the same thing. Are these websites restricting user styles? That would be understandable but why does it auto-delete the styles? That's quite shocking. I wouldn't expect a website to be able to delete styles. Is that what's happening?


  • I don't seem to be able to create any styles right now, using Stylish 2.0.1. I see that it was recently (April 24) updated, which may be where the issue started.

    Different from your experience, though, every time I write a new style and hit "Save", I get a URL with an id parameter (?id=96 in my case)... but when I hit "Back to Manage", that style isn't in the list. And if I manually go to <stylish-url>?id=96 by typing it in on the URL bar, there's nothing there. (Like, literally nothing. I get the edit interface with a completely empty Sections space and no way to add new Sections.) So it appears the style isn't being saved.

    I can visit <stylish-url>?id=95, which is the last style I created that actually worked, and that seems fine. But no matter how many times I try to create a new style, it's always created as <stylish-url>?id=96 when I click "Save", but it doesn't actually get stored and ends up being lost.

    I've backed up all of my styles to a file (which, I notice, ends at style 95 and similarly does NOT include the style I've now attempted to create 5 times in different ways), I'm going to quit and restart Chrome to see if that fixes it. if not, maybe next I'll experiment with deleting and reimporting my styles, or individually exporting the attempted-newly-created one to Mozilla format so I can... I don't know, do something with it. Try to insert it into the JSON export by hand?

    But all in all, it feels like there's a bug in this latest 2.0.1 update that's interfering with style creation, at least in some circumstances.

  • Well, as always... if Stylish addon doesn't work, just try Stylus.
    It's actively developed, fast fixes, fast support, opensource, no spyware, more features - especially for style developers.
    You can import you .json backupfile from Stylish to Stylus.
    (Downloadlinks on top right)
  • edited May 2018 Chrome

    Huh. I actually do use Stylus in Firefox, because Stylish turned into a disaster with the migration to the WebExtensions platform. But I failed to find it in the Chrome Store, last time I went to set up a Chrome profile (I won't pretend I tried very hard), and Stylish had always been working for me in Chrome, at least. Maybe now it's time to switch both browsers to the same extension, finally.

  • edited May 2018 Chrome

    Switched, happy, meh. Sorry, Stylish, you've just failed me too many times.

  • I am trying stylus and it still seems to not be able to style certain sites. It might be that these sites are restricting it.
  • I am trying stylus and it still seems to not be able to style certain sites. It might be that these sites are restricting it.

    There are some sites that run JavaScript in the browser which will interfere with attempts at local styling. Though it's sometimes possible to have an adblocker block those scripts, in turn. (Or, if the site remains even remotely usable under NoScript, you can go nuclear on them).

    However, barring some bug in the browser's security model, no site can delete your local user styles. It might ignore them, but it doesn't have access to remove them. So, if that's still happening, something else (some local problem) is occurring.

  • I am trying stylus and it still seems to not be able to style certain sites. It might be that these sites are restricting it.

    The Chrome Web Store is off limits. What other "certain sites" are you referring to?

  • I actully can't use inspect element, so... i guess i can't use stylus
  • What does that mean you "can't use inspect element" ?
    Nothing happens when you press ctrl + shift + c

  • yup i did ctrl + shift + c and inspect didn't work for meh
  • Inspecting is a default tool in Chrome and FF.
    It does work for everyone unless you didn't break it on purpose.
Sign In or Register to comment.