[Solved] lost functionality logo

edited September 2016 in Style Development Chrome
Hello,

I need some help, I made a userstyle where I replaced the logo with my own one, well it was the exact same one as the original but it was edited to become grey, It didn't let me push the old logo back properly, So I had to do some tricks and managed to somehow swap the logos to the one I wanted, however the logo has lost the functionality of being able to be used to go back to the home page.

Can anyone give me some tips of what to do or check my code for me, much appreciated for any help given.

the logo code starts from line 13

https://userstyles.org/styles/125839/gogoanime-io-anime-blue-haze

Comments

  • edited September 2016 Chrome
    Replace the image switch code with:
    section.banner .banner_left img[src="http://gogoanime.io/themes/default/img/icon/logo.png"] {
    padding-top: 54px!important; /* equal to height */
    padding-left: 140px!important; /* equal to width, minus some transparent excess */
    height:0!important;
    width:0!important;
    background: url(http://i.imgur.com/zC08xsk.png)no-repeat!important;
    }

    section.banner .banner_left {
    padding: 0 30px 0 20px!important;
    }
    Adjust the side "margins" by altering the padding on section.banner .banner_left.
  • @anagrammar Thank you very much Ana! what would I do without you!
  • You're welcome. Btw, if the parent elements are unique, [src] isn't really necessary. I added it to show that it can be used as the selector because it comes in handy in situations where the parent elements are not unique.
  • You're welcome. Btw, if the parent elements are unique, [src] isn't really necessary. I added it to show that it can be used as the selector because it comes in handy in situations where the parent elements are not unique.

    Hm okay thanks for the info :) Ill remember that.
Sign In or Register to comment.