Support for FRITZ!Repeater 3000

About: Fritz!Box Dark (FRITZ!OS 7.xx) OK rating

It's possible to add support for FRITZ!Repeater 3000, please? Some parts are missed, as in the inital page the div box with class "own_device_desc" has white background so the contained information are not readable.

Thank you

Comments

  • [?]
    I don't have a FRITZ!Repeater, so it's difficult to fix.
    Can you sent me a screenshot of the page, so I know what I'm trying to fix? I'll try to add the class, but afterwards, I'd like you to validate the changes.
  • edited September 10 [?]
    I don't have a FRITZ!Repeater, so it's difficult to fix. Can you sent me a screenshot of the page, so I know what I'm trying to fix? I'll try to add the class, but afterwards, I'd like you to validate the changes.

    Sorry for the late reply, the problem is with "own_device_desc" class present in Repeater 3000 that has not black background, so I change manually css code adding:

    .own_device_desc{
        background-color: rgb(30,30,30) !important;        
    }
    

    It's possible to add it in the script?

    Thank you

  • I don't have a FRITZ!Repeater, so it's difficult to fix. Can you sent me a screenshot of the page, so I know what I'm trying to fix? I'll try to add the class, but afterwards, I'd like you to validate the changes.

    This is the buggy part of HTML code of Repeater 3000:

    <div class="own_device_desc">
     <p>FRITZ!Repeater 3000</p>
     <p>
       <span>Indirizzo IP:</span><span>0.0.0.0</span>
     </p>
     <p class="has_ipv6">
       <span>Indirizzo IPv6:</span><span></span>
     </p>
     <p class="has_wlan">
       <span>Rete Wi-Fi:</span><span>SSID_NAME</span>
     </p>
    </div>
    

    Here the issue is simply setting a CSS class selector for "own_device_desc" div class, such that background-color attribute is dark, as I did in previous post.

    Thank you

  • edited September 21 [?]

    I just find another "bug" of CSS class mferror of box in Internet -> MyFRITZ! Account page of FRITZ!Box 7590 so I decided to add to my local copy these code lines in order to fix it:

    .mferror {
        background-color: rgb(70, 70, 70) !important;
    }
    

    So I'm using a lighter color than background one and this is the final result:

    result

    Hope it can be useful!

  • I'm also sorry for the late reply. Thanks for your extensive information! I've added it to the script. Can you verify if it is working correctly?

    I've dropped the '!important' parts. Is this really needed?
Sign In or Register to comment.