Can't update style's CSS code

edited February 2007 in userstyles.org
I can't seem to update the CSS code for this new style I just made... http://userstyles.org/style/show/1853

Just trying to add like 3 more lines of code that I forgot, and it won't let me...just stays the same. I cleared my cache, switched to another firefox profile, tried again and still, it's not letting me update it :/ Is there a time limit between edits or something (I waited about 10 mins already)?

Here's the code I'm trying to add (at the end):

.pages a { border-color: #444 !important; color: #ccc !important; } .pages a.selected { border-color: #666 !important; color: #fff !important; } .pageinfo { border: none !important; }

edit: Thought maybe I didn't notice an error message on the page, but nope....no errors.

Comments

  • Hmm, I can't do it either. I'll debug later today.
  • I also can't change the code for my styles (comments and pictures are fine)
  • I updated mine last night (http://userstyles.org/style/show/1810) and whilst the description was changed the code wasn't and the GM script 404s. I hope you can sort it out soonish as my host isn't working and I've nowhere to host the GM script at the minute.
  • I'm guessing it has to do with Dreamhost updating from Rails 1.1 to Rails 1.2. I'm updating my local copy now to see if I can debug.
  • OK, should be good now. I put in a fix, though I'm not sure why it changed in Rails 1.2. More investigation is required.
  • Yep, seems to be fixed. Thanks.
  • same here, thanks :)
  • edited May 2008
    This problem still exist.

    I can't update my style :
    http://userstyles.org/styles/7016

    I want to add theses lines :

    @-moz-document url-prefix(http://www.clubic.com/afficher-en-plein-ecran-) { /* Correction bug traits */ div[style*="padding: 10px 0px; margin-right: 1px; background-image: url(/style/images/bord_bleu_gauche_droite.gif); background-repeat: repeat-y; background-position: center;"] { background-image: none !important; } }

    Edit : The only way I found to resolve this problem is to mark the old style as obsolete, and create a new one here : http://userstyles.org/styles/7242
    The message and the new ID on the obsoletion form are completely useless, they don't appear anywhere even when updating with the extention..... Some work have to be done here. >_<
  • can't sign in either.
  • edited May 2008
    also having a problem editing my style: http://userstyles.org/style/show/178
    needing to make changes to title, description and code, but "save" button doesn't save anything at all.
  • OK, there were two problems, both related to caching. When you submitted an update it was actually submitting to the cached "show" page instead of the "update" action. Also, the CSS was not being uncached when a style was being updated. I just updated the site to Rails 2.0 so these may have been caused by that. Try it out now.

    I'm not seeing any problems with logging in.
Sign In or Register to comment.