Notice: To Install styles, click the "Show Css Code" button first. The install button will work after that.
The devs are no longer actively involved in the forum, so any bug reports regarding the extension or website should be sent to them directly at contact@userstyles.org.

How can I fix the disappearing checkbox issue in "Color That Site!" generated CSS?

edited December 2018 in Style Development [?]

Hi!

For a long while now sadly the color edits for the website also erroneously hide checkboxes, which is frustrating on login and search pages.
What do I need to seek for and edit in the CSS files generated to manually fix this?

Here's an example:
URL: https://bugzilla.mozilla.org/query.cgi?query_format=advanced

CSS:
https://drive.google.com/open?id=1dDdhDuKX3ozwb6FOooPU02Sd05tLko3t

Comments

  • edited December 2018 [?]

    What do I need to seek for and edit in the CSS files generated to manually fix this?

    knowledge about CSS and debug CSS with Dev Tools to find guilty CSS.

  • What do I need to seek for and edit in the CSS files generated to manually fix this?

    knowledge about CSS and debug CSS with Dev Tools to find guilty CSS.

    Really? I need to search for "knowledge" in the CSS files?
    Very helpful...

  • edited December 2018 [?]

    I updated the OP with an example.

  • Hmm. Apparently if I remove "input" or "-moz-appearance: none !important;" from this line in the very beginning, the checkboxes/radio-buttons won't get hidden:

    input, textarea, select {background-color: #D6D1CD;border-color: #B5BB97;-moz-appearance: none !important;}
    

    The potential remifications of these changes I can't really judge. I went with the moz-appearance property for now. Not sure what it might screw up.

Sign In or Register to comment.