UPDATED - Stylish plugin error: No default preference for popup.checkNewStyles

edited June 2018 in Stylish Chrome

[ Updating the post after realizing the "hidden" tag is not my issue. ]

Love the Stylish plugin, but am having a strange issue. I use this plugin along with Markdown Viewer. All other extensions are disabled. Stylish will -- more than 50% of the time -- do something that cause page rendering to fail. I get a blank page on the screen. I hit reload a time or two, sometimes three or four, and eventually it renders correctly. If I turn on developer mode for chrome and look at the background page views, I see repeated messages in the console saying "No default preference for 'popup.checkNewStyles'". This happens at every page load, even if there are no active scripts for the page.

The error occurs at storage.js:720. I don't know enough about this kind of coding to figure out where the call is coming from.

The problem happens for me regularly. I can always recreate the issue by clicking the reload button twice in rapid succession (but it will happen occasionally even when I don't do that). If I wait a substantial period of time between reload clicks, things generally render correctly. Not always, but usually. The length of time between page reloads seems to be somehow related to this issue.

Any guidance on what this error is, or how to avoid it?

Thanks!


Hi everyone. Love the Stylish plugin, but am having a strange and frustrating issue. I'm setting up a style for local files (and the appropriate box is checked so the plugin can access them). Stylish will -- more than 50% of the time -- give me a blank page. When I troubleshoot with Chrome's inspect function, I see that the style for "pre" contains a style rendering it invisible:

style="word-wrap: break-word; white-space: pre-wrap; visibility: hidden;"

I hit reload a time or two, sometimes three or four, and eventually it renders correctly. I have disabled all other plugins and still see this behavior. If I turn on developer mode for chrome and look at the background page views, I see repeated messages in the console saying "No default preference for 'popup.checkNewStyles'".

I'm not a developer and am quickly lost looking behind the scenes like this.

Has anyone else experienced this behavior? Is there a known issue and/or fix?

Thanks!

Comments

  • edited June 2018 Chrome

    Try adding !important to all of your userstyle's rules, for example:

    pre {
      visibility: visible !important;
    }
    

    Stylish should not add anything in an element's style attribute, last time I checked a couple of years ago it only added style elements under the page root node (you can see it in devtools element inspector). I guess the problem is that something else is setting that attribute, maybe a script inside that local page.

  • Thanks for the response! You guided me down a useful path, and -- for good or for bad -- I've determined that the "hidden" thing is actually a byproduct of using Markdown Viewer (and therefore a red herring for this problem). Something happens when using Markdown Viewer and Stylish together. It's not that anything gets "hidden" per se, but rather the rendering of the page fails, presumably because of the console error message about popup.checkNewStyles. I will edit the post momentarily. Thanks!
Sign In or Register to comment.