I think I found a bug? (An error has occoured using the Stylish database)

edited January 30 in Stylish Chrome
I tried searching this forum but couldn't find any results, so... after downgrading from Firefox Quantum to ESR (for a plugin incompatibility with Quantum), stylish started pushing this error message when I click the "S" icon (I'm lazy and didn't feel like copying the title in case it's important)
image

After messing around with the profile for a while I noticed that storage.sqlite in the profile directory was empty compared to a profile with a working stylish install. I copied the non-empty version to the broken install, and it worked.

To replicate this bug just delete storage.sqlite. It is replaced with a file that is 0kb

Could Stylish be forgetting to check this database is not empty before trying to read it?

Also clicking Ok on that box does nothing.


Additionally, going back to Quantum does not fix the problem.

I can provide a (clean) zipped copy of the profile with storage.sqlite missing, replicating my issue. It contains a working copy of storage.slqite.

Oh, and my version of ESR is 52.6.0 (64-bit)

Comments

  • Upon giving it further thought. The downgrade causing the error is a separate issue (and probably doesn't need to be fixed)

    However messing around with ESR and getting it to create a clean profile (again probably low priority) I have somehow highlighted the same/similar issue.
Sign In or Register to comment.