Update about Userstyles new design release

189101214

Comments

  • edited July 2017 Firefox
    Mikhoul said:

    [...]

    As I stated on my message on Github I seriously think about starting a new Userstyles very soon. I've already forked Userstyle.org since 2 months and if everything goes fine an nobody took over I will take over in 2-3 weeks and pay for the hosting, domain name etc.. It will be funded by the advertisements which should be enough to keep it running.

    [...]
    Eager to see a working site. However I'd suggest to start with a new forum as a base.
    Note you forked https://github.com/mikhoul/userstyles a version that is not the last one touched only by Jason https://github.com/stylish-userstyles/userstyles/tree/ecca01823f299a557d4355e775282b8a4d13e323
    Mikhoul said:

    [...]

    It's hard for me to understand how they have messed this site since the only changes IMO they had to do were to change the CSS and leave mostly everything else the same.

    But they seem to have opted to make a big change of everything at the same time without testing it locally.

    Maybe they have hired low-cost/cheap devs (in Asia usually) to develop the "new" website since it's so long before any changes appears and the peoples who do the change don't seem to understand how the web site works AND what is the purpose of this website.

    [...]
    What they apparently did is to use a system/platform for making prefab sites to adapt the old site: https://www.invisionapp.com/
    (see https://forum.userstyles.org/discussion/comment/112965/#Comment_112965 @JourneyOver )

    [...] and destroying its dedicated users [...]

    If that's not the point for both Firefox and userstyles.org they dissimulate quite well.


  • calico女 said:

    Wishing you good luck. Thank you also for updating us. It is appreciated.

  • Gosh this new design is both un-aesthetically pleasing, and broken.
    You know you could have kept the old design? I liked the old design better.
    This used to be one of the very few websites that kept their old designs, and I really liked that. But now it had to be up-to-date with all the others for no reason and it looks so different that it's overwhelming.
    Also things in it are kind of slipping off some parts, some options are gone, and many other bugs according to everyone else.
    I know my reasons aren't that good, but, I just had to criticize the new design.
    Liked the old one better for it's design and function.
  • Waterfox

    Gosh this new design is both un-aesthetically pleasing, and broken.
    You know you could have kept the old design? I liked the old design better.
    This used to be one of the very few websites that kept their old designs, and I really liked that. But now it had to be up-to-date with all the others for no reason and it looks so different that it's overwhelming.

    I personally prefer the old legacy look too. But there were many requests for an updated 2017 look, and that's what we got. The great thing about learning Css though, you don't have to settle for someone else's idea of a great looking website. You can code your own.
    1579 x 762 - 348K
  • A current problem with Userstyles is nothing appears for me! I just get an empty page when viewing anything on Userstyles other than the forums so I can't edit my styles' CSS on here to update them!
  • Ah so this thread explains why I cannot find the styles I want. I thought maybe the old userstyles.org Stylish theme I had installed was broken. What *is* the default sort algorithm? Total download numbers? With no regard to last update? I'm seeing very popular themes--from 2012!
  • Hey Guys is it normal that there aren't any images/screenshots/gallery with the uploaded styles?
  • Something major seems to be broken. My normal link to a search doesn't load, and if I navigate via front page, no images available at all. Also, style doesn't update if I make changes, such as try to upload a new image.

    Is no-one maintaining this site? Implementing the new site brought one hell of a lot of broken functionality, and now it seems that some kind of update also breaks the site, but no backup or immediate rollback? Something in your processes is seriously broken folks!

    This is no way to run ANY website, let alone one that has been built up uniquely through the hard work and many hours of its users.
  • Hey Guys is it normal that there aren't any images/screenshots/gallery with the uploaded styles?

    Something major seems to be broken. My normal link to a search doesn't load, and if I navigate via front page, no images available at all.

    Well, at least you can see the website, right? That's more than I can say. I'm getting a blank page unless I disable AdBlock... and I really don't want to disable AdBlock, so that's it. I'm gone from here. I'm done with Userstyles. I'm mentioning it because perhaps you have differently setup your AdBlock, so try turning it off, perhaps it will work for you. Oh, and by the way... I had Userstyles whitelisted, so this is really a dick move it they've done it on purpose.
  • edited August 2017 Firefox
    What's that new "Editor's Choice"? More "Editor's Styles" actually, added in first in every lists??
    https://userstyles.org/styles/browse/facebook
    However, main screenshot seems to be no blurry anymore...
    One step forward, 2 steps back...
  • So, need to delete cookies and image cache in the browser to get the site to appear properly again.
  • edited August 2017 Firefox
    Did the install problems finally get addressed? Having style authors get down votes or posts like this if it's a site/extension issue is unconscionable.

    image
  • edited August 2017 Firefox
    Talbis said:

    I'm getting a blank page unless I disable AdBlock... and I really don't want to disable AdBlock, so that's it. I'm gone from here. I'm done with Userstyles. I'm mentioning it because perhaps you have differently setup your AdBlock, so try turning it off, perhaps it will work for you. Oh, and by the way... I had Userstyles whitelisted, so this is really a dick move it they've done it on purpose.

    The site you need to allow is freegeoip.net, currently used to customize by country. See: https://forum.userstyles.org/discussion/57758/more-analytics
  • Jefferson said:

    The site you need to allow is freegeoip.net, currently used to customize by country. See: https://forum.userstyles.org/discussion/57758/more-analytics

    Don't care, not gonna happen. Also, customise by country as in targeted ads? They've worked fine before, as I had Userstyles whitelisted, now a blank page, despite me not blocking anything (again, whitelisted) so... this makes no sense. I can and will use the forums, as for the website itself, it's too broken to use anyway.
  • I know I shouldn't be doing your job for you but here is the problem code:
    In scripts/globalStateHandler.js (using sourcemaps, deployed code is minified)

    init(reactApp) {
        this.app = reactApp;
        this[p].clientCountry = JSON.parse($.ajax({
            url: "https://freegeoip.net/json/",
            async: false,
            type: "GET"
    
        }).responseText).country_name.toLowerCase();
        this.app.state = this[p];
        this.fetchTopSitesByCountry();
        this.initEventListeners();
    }
    

    which obviously results in a null pointer if the ajax request does not return the proper JSON. Should be easy to fix:

        var response = JSON.parse($.ajax({
            url: "https://freegeoip.net/json/",
            async: false,
            type: "GET"
        }).responseText);
        if (response && response.country_name) {
            this[p].clientCountry = response.country_name.toLowerCase();
        }
    

    Also using a synchronous xhr is generally a bad idea but that is less simple to fix.

  • strel said:

    If that's not the point for both Firefox and userstyles.org they dissimulate quite well.

    Well now they for sure fucked us with 55 wiping the remaining status bar for good.
  • I joined to say that the only way I can find anything on your newly vamped site is to use Google advanced search. I've got scripts currently installed that do not appear on a search from your website, yet they appear from Google advanced search.
  • Why bold code not working in description :((
  • Why bold code not working in description :((

    add style="font-weight:bold;"
  • Please add an option to revert to the classical interface! Call it basic HTML view, designed for older browsers but you can still load it anyway if you want.
  • edited September 2017 Firefox

    I'm really impressed by the rebuild of everything. Thank you for all that are involved. However I have 2 issues:


    1. When the site displays list of styles, I can't open the style pages in new tab using CTRL+Click like every links should always be.

    2. I wish there's uninstall button in the individual style pages along side the install button.
  • rismanrp said:

    I'm really impressed by the rebuild of everything. Thank you for all that are involved. However I have 2 issues:


    1. When the site displays list of styles, I can't open the style pages in new tab using CTRL+Click like every links should always be.

    2. I wish there's uninstall button in the individual style pages along side the install button.
    Impressed?? That's something new to read
  • He's joined today and leaves a positive comment.
    I smell something fishy...
  • Something funny been happening today.

    For some reason, on install, the CSS code is being separated into two parts and the second part is not being assigned a domain to apply to automatically. This means that all websites become styled with the userstyles from userstyles.org until I assign a domain to the second section 'code 2'.

    Is there something I now need to add to the CSS to stops this happening. I have lots of settings on my style.

    https://userstyles.org/styles/105096/todoist-advanced

  • Something funny been happening today.


    And every time I do an update of the style, it reverts back to applying code 2 globally.
  • Also, now when you update style, the button reverts to 'style installed', which means users have to do a reload to tweak any of the settings, and in doing so, they lose all their previous settings because it reverts to default.

    Please, you have to understand that style settings are a crucial part of the functionality of userstyles - stop messing around with them. Set up a cookie to store a users settings, and use an 'reset to defaults' button to users a chance to start again.

    I only just told my users how to use the 'update style' button without page reload to tweak the settings, and now that functionality has disappeared. Getting depressing!
  • Right, I just discovered that this useful behaviour was down to Stylus, not the Stylish addon. Amazing how a fork can get something essential like that implemented, but the devs on the main Stylish addon are continuing with compromised functionality.
  • edited September 2017 Firefox
    Hi Mark Phillips, while userstyles.org has always had an (in my opinion) overly complicated way to implement style options, at least they used to work. Unfortunately I'm not aware of an alternate host that is anywhere near as convenient as this one. (And since I don't understand Ruby, I can't operate a site based on the old code of this site.) Hopefully someone will step up to cater to authors of more complex styles. If not here, then elsewhere.
  • Also, now when you update style, the button reverts to 'style installed', which means users have to do a reload to tweak any of the settings, and in doing so, they lose all their previous settings because it reverts to default.

    That's a problem I've started to notice since the new design first appeared; Any time I upldate one of my customizable styles, all settings revert to default! As with every flaw of this design, there's no excuse; The old design did them all fine.

    If only a version of UserStyles that was better existed, like the old website on a different domain. If so, it'd be like Stylus is to Stylish.
Sign In or Register to comment.