Notice: The devs are no longer actively involved in the forum, so any bug reports regarding the Stylish extension or this website should be sent to them directly at contact@userstyles.org.
Changing your Avatar.
The only way to currently change a forum avatar is through Gravatar.com. The email address used for your Userstyles.org account must be one of the email addresses that is registered to your Gravatar account.

Stylish broken in latest nightly

in Stylish Default Browser

Stylish doesn't load any user styles and I see these errors in the browser console:

TypeError: stylishOverlay is undefined
onclick()
TypeError: stylishOverlay is undefined
onpopuphiding()

Comments

  • I noticed the same issue today running Nightly 46.01a. Not only are my custom styles not loading, but I can no longer even access them. The Style Manager seems to only work from the web now, instead of giving me direct access to the styles for editing.

    What's up with that?
  • Default Browser
    My guess is that the latest Nightly update is the issue.
  • edited January 2016 Firefox

    This is caused by a commit in the latest Firefox nightly : https://bugzilla.mozilla.org/show_bug.cgi?id=1220564

    Temporary fix is to change in the file : components\stylishStyle.js

    This : return [toHexString(hash.charCodeAt(i)) for (i in hash)].join("");
    ... to This : return Array.from(hash, (c, i) => toHexChar(hash.charCodeAt(i))).join("");

  • Default Browser
    Yup, that does the trick.
  • So the old syntax will no be accepted and wherever it is used will have to update... ...which means Stylish (and possibly other extensions) will need an update. I am surprised and glad only one line of code is affected, but it seems to work fine after just that change. Thanks for the information, Peja.
  • Default Browser
    It was a non-standard syntax that they strongly recommended not to use, luckily extension makers have plenty of time before this gets into a final release.
  • edited January 2016 Firefox
    So how to we fix the issue if that file doesn't exist? 'Cause I don't have it.

    (Yet, Stylish IS installed.)
  • edited January 2016 Firefox
    Jim Simon said:

    So how to we fix the issue if that file doesn't exist? 'Cause I don't have it.

    (Yet, Stylish IS installed.)

    Should be components\stylishStyle.js in
    %profiledir%\extensions\{46551EC9-40F0-4e47-8E18-8E5CF550CFB8}.xpi

    extract the .xpi to a test folder using 7-zip, and re-zip after editing using 7-zip as :
    format: zip
    level: fastest
    method: deflate

    Make sure firefox is not running when you do this process.
  • Hopefully an update to stylish is pushed out at some point today.
  • edited January 2016 Firefox
    Thanks for the info, Peja.

    I must still be missing something, though. After the change and rezip, I renamed the new .zip file to XPI, and the extension showed as no longer installed.

    What's more, even before playing with the file, the Stylish site will not let me install any styles, claiming I need to install Stylish first.

    But it WAS installed.
  • When I did it, I removed the folder named META-INF. I also changed the about:config setting xpinstall.signatures.required to false. I did everything in a separate folder and then I installed the xpi (I get a warning!). I am not sure if removing the folder was necessary, but I guess it may be needed to break Firefox security.
  • I have just verified this issue was fixed in the repository a few hours ago (using very traditional syntax). An update may be soon (if not already) in the review process.
Sign In or Register to comment.