Stylish Editor²

17810121339

Comments

  • Sonny,
    I am VERY interested in these 2 addons; however, i'm finding it confusing to figure out what changes they make/problems they solve. Could someone please either point me to the thread or write a short explanation of these 2 addons:
    Stylish Editor Mod v2.0.0 (contains editor management tools): https://dl.dropboxusercontent.com/u/77691265/stylishmod200.xpi
    Also integrates with my Addon Manager Fix v32.0.3: https://dl.dropboxusercontent.com/u/77691265/amfRelease200.xpi
  • edited June 2015 Firefox
    Start here:
  • Any explanation for the Undo All button? Why do we have it if it doesn't work?
  • @makondo,
    "Any explanation for the Undo All button? Why do we have it if it doesn't work? "
    Nope, works fine here.
  • How dose it work though? I click it and nothing happens.
  • edited January 2015 Firefox
    For example, I have this:
    @-moz-document url-prefix(chrome://inspector) {
    treechildren:-moz-tree-row {

    I delete both brackets, like so:
    @-moz-document url-prefix(chrome://inspector)
    treechildren:-moz-tree-row

    I click Undo once and get:
    @-moz-document url-prefix(chrome://inspector) {
    treechildren:-moz-tree-row

    I click Undo a second time and get:
    @-moz-document url-prefix(chrome://inspector) {
    treechildren:-moz-tree-row {

    I delete both brackets and click Undo All and goes from this:
    @-moz-document url-prefix(chrome://inspector)
    treechildren:-moz-tree-row

    To this:
    @-moz-document url-prefix(chrome://inspector) {
    treechildren:-moz-tree-row {
  • I don't get it. Some times it works and then some times it does nothing!
  • Does it work consistently for you?
  • Sonny,
    do you know what the id for the label next to UNCHECKED checkboxes in the settings popup? I have this for the checked boxes but i now need to style the UNchecked labels:
    #stylish-edit #settings #options-popup label
  • edited January 2015 Firefox
    .checkbox[checked] + .label
    and
    .checkbox:not([checked]) + .label
  • That didn't work but i discovered that this code in my UI style has something to do with it: label.radio-label
    I changed the color there and it's fine now (but adding radio-label to my Editor style doesn't work, the UI style must be overriding it). It's OK, it's readable now and is good enough. Thanks!
  • Sonny,
    i just posted a style and noticed the name field on the us.o edit page gets filled with the code instead of the name but the css box is empty:
    image
    429 x 113 - 75K
  • edited June 2015 Firefox
    OK, I see that, as well.

    Try this:
  • Good now, thanks!
  • Still having major probs with raising ram and crashes, i deleted prefs.js and ... lost all tags! Now i have to re-tag all 230 styles. Is there any way to save them?
  • edited January 2015 Firefox
    Yes, before deleting prefs.js, use the Export prefs button from the Settings dropdown menu in the Stylish Editor. After fresh install, Import prefs from same dropdown menu, pointing to where the saved file is located.
  • From here:
    440 x 393 - 39K
  • Are we talking about styles tags? 'cause i did import settings but tags don't show.
  • Wait one, will check.
  • edited June 2015 Firefox
    Updated:
    When importing prefs, need to refresh Addon Manager to view tags.
  • Well, i can't tell you if it works 'cause i hope i'm not doing it again any time soon. In the mean time i will be re-tagging all 232 styles ...
    Here's the really mysterious part: i re-tagged a few and this time changed the old tag slightly. Like, instead of the old 'Exts' tag i uses 'extensions'. And instead of 'Sites' i used 'sites'. Now, guess what i'm seeing after restart!
    image

    Yes! Those are my old tags!!! Sio, apparently they're saved somehow somewhere but just don't appear in the editor Tag box.
    368 x 260 - 129K
  • Also, the scroll buttons quit working for me (AMF). reinstalled from the first page - no, still not working.
  • edited January 2015 Firefox
    Just switched to fx 36 Beta. Are you saving the style after renaming tag (required)? Tags change for me and also, yes, the scroll button doesn't work in Beta, checking.
  • edited June 2015 Firefox
    Fixed scroll button for Beta:
  • I save styles after re-tagging. They all had tags before i did the prefs.js switch. None had them after that and i now have to re-tag them all.
    But this is the least of my probs right now. My default profile is very unstable now. I'm going to switch to my old prefs.js 'cause deleting it didn't solve my problems with rising ram. If i continue having issues ... i will have to reset the profile and start from scratch. Fun + some ...

  • edited January 2015 Firefox
    I still believe you have an addon/script/CB that is not releasing your memory after it is closed.
  • Well, i disabled all exts. (half and then the other half), didn't help. Scripts? - i have only yours and one pretty old but still working fine for YTube (called UsableTubeFix, used to be on US.O but now i don't even know where to find it, have a local copy, that's what i use):
    CBs? I was thinking that. But why now all of a sudden? Everything was working until the end of last month ... i believe. I didn't install any new buttons, didn't edit any (as far as i can remember).
    The problemis it';s not just rising ram after i close the browser but afte i close any additional window which is not a browser window per sei but DOMi, for instance (especially if a site is displayed in there), TMP attachement small popup, AM in it's own window, etc. It jumps about 200MB on loading and then another 2-300MB on closing those windows making it imposssible to edit styles w/out a crash. I can see it rising up to 7-8 and save a stytle in a hurry, close, close DOMi and exit Fx before it crashes. At this point it jumps another 200 MB and some times crashes some time does not. I can't get anything done anymore! And now us.o main and CB forum sites don't fully load! Do they load all right for you?
  • Have you tried deleting DOMi and install anew?
Sign In or Register to comment.