Bibliothek show more

edited July 2014 in Style Requests
I loose a style for the bibliothek that's expands the "less/more" (Weniger/Mehr) as standard.
You can see what I mean in "2 I like this.jpg"

Can you help me?

thx
Quaser
300 x 140 - 10K
297 x 233 - 15K

Comments

  • @-moz-document url('chrome://browser/content/places/places.xul') {
    #infoBox row[hidden="true"] {display: -moz-grid-line}
    #infoBox checkbox[hidden="true"] {display: -moz-box;}
    #infoBoxExpanderWrapper {display: none}
    }
  • Thank you :)
  • The script do not longer run under Firefox 57.
    Can you help me?
  • Änderungen am Browser selbst sind nicht erlaubt. Wenn du das trotzdem willst, musst du es in die userChrome.css eintragen.

  • Die [userChrome.css] liegt im Verzeichnis [chrome] im Firefox-Profilordner.

    Der Inhalt:
    #urlbar-go-button { display: none !important; }

    @-moz-document url('chrome://browser/content/places/places.xul') {
        #infoBox row[hidden="true"] {display: -moz-grid-line}   
        #infoBox checkbox[hidden="true"] {display: -moz-box;}
        #infoBoxExpanderWrapper {display: none}
    }

    Läuft trotzdem nicht.
  • If the library is opened as a tab in the browser, the code posted by @hideheader must also be placed in the userContent.css file.
  • Jup, probier's mal in der userContent.css. Ist genau das gleiche wie bei der userChrome.css, nur anderer Name. Ich dachte, da es sich nur um das Popup handelt, wäre es in der userChrome.css richtig, aber Versuch macht klug.

  • Ist immer noch das gleiche.
    Die userContent.css liegt im Firefox-Profilordner, Unterordner chrome.
    Inhalt wie gehabt.
    Wenn ich die Bibliothek öffne, ist Mehr nicht aufgeklappt.
  • Mmhm, die Identifier haben sich wohl geändert. Ich habe aber Probleme beim Inspizieren.
    Der Kasten heißt jetzt #detailsDeck. Du könntest auf gut Glück einfach mal probieren, #infoBox mit #detailsDeck zu tauschen.
    Und testweise auch in beide userChrome.css und userContent.css reinmachen.

    Wenn der Ausklappmechanismus geändert wurde, muss man evtl. sogar mit JavaScript ran und einen Klick simulieren, aber Mozilla setzt meistens eher auf die CSS-Lösung.
    Da kann ich grade aber auch nicht weiterhelfen.

    @Joao Sorry for changing language, didn't want to be rude!

  • I tested this code in Firefox 58 beta and it works normally.
  • @Joao Sorry for changing language, didn't want to be rude!

    Ok, no problem.
  • Ich habe jetzt eine userChrome.css und eine userContent.css in Profilordner.

    Inhalt:

    #urlbar-go-button { display: none !important; }

    @-moz-document url('chrome://browser/content/places/places.xul') {
        #detailsDeck row[hidden="true"] {display: -moz-grid-line}   
        #detailsDeck checkbox[hidden="true"] {display: -moz-box;}
        #detailsDeck ExpanderWrapper {display: none}
    }

    Firefox 57.0.4, 64 Bit
    Geht trotzdem nicht
  • edited January 21 Firefox

    Ich kann grade auch nur raten, weil ich zu doof bin, es im Inspektor zu finden.
    Probier mal nur

    #urlbar-go-button { display: none !important; }
    #infoBox row[hidden="true"] { display: -moz-grid-line !important; }   
    #infoBox checkbox[hidden="true"] { display: -moz-box !important; }
    #infoBoxExpanderWrapper { display: none !important; }
    #detailsDeck row[hidden="true"] { display: -moz-grid-line !important; }   
    #detailsDeck checkbox[hidden="true"] { display: -moz-box !important; }
    #detailsDeckExpanderWrapper { display: none !important; }
    

    in beiden Dateien. Achja und FF Neustart nicht vergessen bei Änderungen an diesen Dateien.

  • Es wird nur die userChrome.css benötigt.

    keine Änderung
    #urlbar-go-button { display: none !important; }
    #infoBox row[hidden="true"] { display: -moz-grid-line !important; }
    #infoBox checkbox[hidden="true"] { display: -moz-box !important; }
    #detailsDeck checkbox[hidden="true"] { display: -moz-box !important; }
    #detailsDeckExpanderWrapper { display: none !important; }

    blendet MEHR komplett aus
    #infoBoxExpanderWrapper { display: none !important; }

    Der hier ist lustig: blendet die Beschreibung ein, und trotzdem hat man noch das Feld MEHR. Das tut es für meine Zwecke, weil ich ja nur die Beschreibung sofort sehen wolle.
    #detailsDeck row[hidden="true"] { display: -moz-grid-line !important; }

    Danke. Hätte ich nie hinbekommen.
    522 x 235 - 17K
    452 x 255 - 17K
  • Danke für das Feedback. Dann lag ich zumindest mit der userChrome.css richtig und beim Rest... sagen wir, Hauptsache es geht :-)
  • Seit dem Update auf Fx 58.0.1 (x64) wieder ohne Funktion
  • Inspizieren klappt jetzt.
    Eigentlich sollte #detailsDeck row[hidden="true"] { display: -moz-grid-line !important; } noch immer funktionieren. Das ist die wichtige Zeile. Ich sehe keine Änderung bei FF58.
    Das Feld "Mehr" ausblenden ist nur Kosmetik.
    Du könntest höchstens mal versuchen, die Felder direkt anzusprechen:

    #editBMPanel_keywordRow, 
    #editBMPanel_descriptionRow { 
        display:-moz-grid-line !important; }
    

    Als Wert kannst du auch ruhig mal -moz-box oder block probieren.

Sign In or Register to comment.