Stylish Custom²

13468967

Comments

  • Sorry, missed your post above. I don't want you to keep special versions for me. I'd like to use yours and i can style stuff for my use. Just like any other ext. I'm doing all right so far.
  • edited October 2013
    Ensure to use Default Theme and New searchbar in the options. The Default Theme only contains the default css. Need to add code to hide New findbar if old search is used.
  • edited October 2013
    Stay tuned, findbar is not working. Something is very wrong with those bars. I'm getting confused what to use. Is the 'old' one with arrows? It doesn't work.
    The arrows are in reverse, Next should be first, Previous should be second (if placed on the right of the bar). I see them backwards.
  • OK, i'm done. So, the whatever search bar is nnot working, i can't style the 'Next' button, it takes the same image as #stylishCustomToolbox #FindNext even though it has its own ID. I'm thinking it's because they both show.
    I'll wait for a fix (to hide unused search bar) and see what happens.
  • I have another problem (don't mean to interrupt you, just reporting). The options don't save. I check Hide Statusbar icon/OK/close Options. Open Options - Show is checked every time. It doesn't save the change. I don't see the button anyway since i place them on the top toolbar but the option doesn't save.
  • edited October 2013
    (1) Permanently hid the old search findbar, along with it's settings in the options, and will only show new search findbar, with next/previous buttons.
    (2) Reset all the applicable radio prefs to reflect correctly in the Options dialog.
    (3) No CSS changes.
    https://dl.dropboxusercontent.com/u/77691265/XSCMod3.xpi
  • Great, thanks!
    Still a problem with the CommentGroup - it doesn't replace comments when clicked the second time (to UNcomment).


    /* test */
    textbox
    { border: 1px solid rgba(0,0,0, .4) !important; }

    /* test */
    textbox
    { border: 1px solid rgba(0,0,0, .4) !important; }

    Click CommmentGroup and you get this:

    /* COMMENT GROUP 3
    test
    textbox
    { border: 1px solid rgba(0,0,0, .4) !important; }

    test
    textbox
    { border: 1px solid rgba(0,0,0, .4) !important; }*/



    Now click CG again and you'll get this:


    test
    textbox
    { border: 1px solid rgba(0,0,0, .4) !important; }

    test
    textbox
    { border: 1px solid rgba(0,0,0, .4) !important; }


    But it should return code to its original state:

    /* test */
    textbox
    { border: 1px solid rgba(0,0,0, .4) !important; }

    /* test */
    textbox
    { border: 1px solid rgba(0,0,0, .4) !important; }


    * And, of course, i still don't get the numbering thing. What's the purpose of that anyway? image
  • edited October 2013
    Some users wanted a way of tracking the number and order of their comment groups. The Reset to 0, in the options, simply resets comment group count back to 0.
    EDIT: OK, done. https://dl.dropboxusercontent.com/u/77691265/XSCMod3.xpi
    Replaces all /* and */ within the comment group with ⫸ and ⫷ respectively. Vice versa on second click. Symbols can easily be swapped out with others. Symbols are unique to the group and easier to identify!
    Toggle Comment button can also be used to uncomment a group.
    First click:
    /* COMMENT GROUP 1
    ⫸ test ⫷
    textbox
    { border: 1px solid rgba(0,0,0, .4) !important; }

    ⫸ test ⫷
    textbox
    { border: 1px solid rgba(0,0,0, .4) !important; }*/

    Second click:
    /* test */
    textbox
    { border: 1px solid rgba(0,0,0, .4) !important; }

    /* test */
    textbox
    { border: 1px solid rgba(0,0,0, .4) !important; }
  • edited October 2013
    image It's working! Thank you!
    There's one annoying thing that has been around for years in the original and is still happening:
    when you highlight a block to ConmmentGroup (i don't think this happens with CommentText,) and click CG button, the first line (/* Comment Group 0) jumps up creating its own line where i had a space. When you UNcomment, the block you just commented & uncommented, it will remain on that line, eliminating one line spacing. Like so:

    1.
    /* test */
    textbox
    { color: red !important; }

    /* test */
    textbox
    { color: blue !important; }

    /* test */
    textbox
    { border: 1px solid rgba(0,0,0, .4) !important; }

    2.
    /* test */
    textbox
    { color: red !important; }
    /* COMMENT GROUP 10
    ⫸ test ⫷
    textbox
    { color: blue !important; }

    ⫸ test ⫷
    textbox
    { border: 1px solid rgba(0,0,0, .4) !important; }*/

    3.
    /* test */
    textbox
    { color: red !important; }
    /* test */
    textbox
    { color: blue !important; }

    /* test */
    textbox
    { border: 1px solid rgba(0,0,0, .4) !important; }

    I don't know why it does it and when, it doesn't happen every time but often enough to annoy 'cause i have to hit space to have it the way it was. Do you have any idea if it's something i do wrong or something in the editor or SC code?
  • edited October 2013
    Don't know how that is possible. Not suppose to happen and never has, for me. Only affects selection and nothing that is not. Will only happen when that space is part of the selection. Ensue you are not selecting that space (spaces don't get highlighted).
  • OK, maybe it's my doing, being sloppy image
    Anything else on the 'wish list' you might add/change?

  • Added END COMMENT and it's number to the end of group, for better visualization. https://dl.dropboxusercontent.com/u/77691265/XSCMod3.xpi

    /* COMMENT GROUP 1
    ⫸ === scrollable panels ⫷
    BODY[class="Vanilla Discussions index "] #Content > UL,
    BODY[class="Vanilla Discussions bookmarked "] #Content > UL,
    .Condensed.DataList.Conversations
    { height: 744px !important;
    overflow-y: scroll !important; }

    ⫸ === 'More' link ⫷
    #PagerMore
    { position: fixed !important;
    top: 3% !important;
    left: 0% !important; }
    END COMMENT 1 */
  • edited October 2013
    Nuts. I lost my search bar on the last update. image

    Rolling back to a previous one (1.3.3).

    Thanks for making different iterations available, Sonny! image
  • What version of Fx are you using?
  • Nightly ... 27.0a1

    64 bit but I don't think that makes a difference.
  • edited October 2013
    OK, loaded into Nightly and indeed the findbar not working yet. It does in Aurora, so perhaps the update for the findbar in Nightly will be coming shortly. If you open the Customize Toolbar Palette from the Editor and then close it, you will see the Findbar, but does not function.
  • edited October 2013
    Thanks for looking into it, Sonny. I tried the customization thing and then closed it (the close button still doesn't work but I've read you're working on it) and still no change - still no search bar (or find bar).

    In the meantime, I'll stick with 1.3.3.
    You've done an awesome job! image
  • edited October 2013
    Yes, indeed. It's in the findbar.xml file. Updated the file myself and the findbar now works in my copy of Nightly. Problem is, you will probably lose it on an update, untill the dev's get around to updating it themselves.

    image
    740 x 308 - 67K
  • edited October 2013
    Guess I'll have to give up the "Next" and "Previous" buttons for a bit.

    I'll try and let you know when it gets fixed but Mozilla are changing a lot about the findbar.
    Thank goodness for your Custom Button in relation to such. image
  • edited October 2013
    Sonny,
    thanks for the update! Having the comment end helps to spot it easier.
    Can i change the commented symbols with a css? Don't have to, just asking if i'd want to play with it.
  • edited October 2013
    No, it's generated by the script.
  • OK, Thanks!
  • edited October 2013
    Added a Findbar button that will show/hide findbar and associated elements (saves real estate when not needed) . Also fixed the OK button in the Options dialog to function correctly. https://dl.dropboxusercontent.com/u/77691265/XSCMod3.xpi

    image

    image
    744 x 58 - 9K
    744 x 57 - 10K
  • edited October 2013
    Hehe, by 'correctly' i guess you mean close the window.

    Got it, thanks for the update!
  • edited October 2013
    WindowsVista Firefox24

    Thanks very much Sonny for the update and the Findbar Arrows !
    I'm back in the game!


    #1
    No it has nothing to do with tracking the number and ORDER of comment groups.

    It is if you have more than one CommentGroup in an editor.
    If you CommentGroup one, then CommentGroup a second one, when you UNcommentgGroup, they will both UNcommentGroup to the same code IF YOU DO NOT HAVE A MEMORY NUMBER SYSTEM.


    EXAMPLE:
    CommentGroup the tab code, then CommentGroup the body code SEPARATELY as two different CommentGroups.
    When you UNCommentGroup, the second one would UNCommentGroup exactly the same as the first one. Because the number system is a MEMORY for UNCOMMENTGROUPING.

    /*TAB TEXT COLOR*/
    tab
    {color: /* red */ blue !important;
    /* text-decoration: none !important; */}


    /*WEBPAGE BACKGROUND COLOR*/
    body
    {background: black /* grey */ !important;}


    #2
    My symbols don't show as symbols in my editor, or any editor, or on the webpage.



    #3
    Automatically insert !important;
    Works fine now thankyou.

    #4
    EXPORT: Like makondo said...Path appears double. Firefox24


    #5
    EXPORT: Will only Export 100 styles maximum. And I have 500 styles.
    Could it be changed to max 500, or 700 or more please?


    Thankyou!



    EDIT:
    ● Yeah... I still haven't updated my StylishCustom Editor for this Mod, so ignore the mess.
    ● My FindbarArrows functions fine thankyou. No issues with it.
  • edited October 2013
    A quick question: why is it with every update toolbarbuttons ignore my style and appear as toolbarbuttons, with a bg that is?
    I've already have this and thought i got it all but no, here we go again!

    stylishCustomToolbox > toolbar toolbarbutton, stylishCustomToolbox toolbarbutton, stylish toolbarbutton (i can't post the real code as this site has a problem with html, you know)

    ... this should look like this
    image

    But right after any of the last updates, it looks like this ...
    image

    ... and i have to open the style, edit (or not, not sure about this one), save and then it looks all right again. Why is that?
    158 x 112 - 24K
    236 x 162 - 54K
  • edited October 2013
    All my styles get exported, all 250 of them at this point.

    Sonny,
    i don't use search/replace checkbox. I'd like to switch it with the Clear search button but ordinal group code doesn't work and margins don't work either. Any ideas?
  • edited October 2013
    @makondo,
    See if this update cures your button background issue: https://dl.dropboxusercontent.com/u/77691265/XSCMod3.xpi
  • edited October 2013
    The latest update messes with any "FindBar" actions.

    I tried to roll back to the 1.3.3 which worked for "Find" albeit without the "Previous" and "Next" buttons but it appears to be borked as well. image

    1.3.3:, I tried to type in "user" and click "Next" ... or "Previous" ... nothing ...

    image

    510 x 246 - 65K
  • What happened? Right now, I want my old 1.3.3 back. Shoulda saved it, I guess ...image
Sign In or Register to comment.