Stylish 1.0.6 progresschunk bug (Solved | It was not a bug after all)

edited August 2009 in Stylish
A bug introduced in Stylish 1.0.6 broke the code below which is meant to apply the system progresschunk to the tab progress bar. Stylish 1.0.5 and earlier are not affected by this bug.

tab .progress-bar { -moz-appearance: progresschunk !important }

Comments

  • How do you get a progress bar on tabs?
  • edited August 2009
    Tab Mix Plus adds the tab progress bar. The above Stylish code makes the tab progress bar use the progresschunk from your system theme instead of the Firefox (?) default.
  • Is that the entirety of the style you're using, or is it just the portion that's not working?
  • Tried the posted code with Tab Mix Plus and it works for me on Linux.
  • edited August 2009
    It's just the portion which is not working. Here is the extent of what I'm using http://pastebin.com/fd069ede (originally a theme found on userstyles.org which I modified) .

    I'm on WinXP SP3 x86. Without the code above the progress bar is a ugly flat purple, with the code it is a shiny blue (which is the progresschunk from my system theme).

    Correctly displayed using Stylish 1.0.5 and earlier: http://img134.imageshack.us/img134/4900/105h.png

    Broken (not doing anything) with Stylish 1.0.6: http://img36.imageshack.us/img36/1540/106bau.png

    I think progresschunk is Windows specific (?) so I don't believe the code would do anything on Linux, but it's not my code (originally snipped it from something on userstyles.org) so I'm not intimately familiar with exactly what it does internally. All I know is some change in Stylish 1.0.6 is causing it to no longer work with the above code.
  • The problem is likely the data URIs in that style. The ones on lines 251 and 266 have line breaks. If you press Preview on that style, it'll show you the errors. This is indeed a change in 1.0.6.
  • edited August 2009
    You're correct. Moving the code to it's own userstyle seems to fix it with Stylish 1.0.6, so there is something funky going on with that long style that broke that code at the end.
  • All you have to do is remove the linebreaks on lines 251-258 and 266-272, inside the data URIs. If you turn off word wrap, it'll be easier to see.
  • It seems the two areas throwing errors were as follows:
    /* Translucent dialogs (too dark for vistaglazz toolbars) */ @-moz-document url(chrome://global/content/commonDialog.xul) { dialog { background: url("data:image/png;base64, iVBORw0KGgoAAAANSUhEUgAAABQAAAAUCAYAAACNiR0NAAAABGdBTUEAAK/INwWK6QAAABh0RVh0U29 mdHdhcmUAUGFpbnQuTkVUIHYzLjA4ZXKc4QAAAC9JREFUOE9j5LcMWsxATQAykJqYgZqGgX07aiDFET QahpQn8tEwHA1DMsrKwZ9sADuo19oANiVcAAAAAElFTkSuQmCC") !important } description, checkbox { color: white !important; font-family: Tahoma, Calibri, sans-serif !important; font-size: 11pt !important } vbox > description { font-weight: bold !important } }

    /* Transparent tooltip */ tooltip { -moz-appearance: none !important; background-color: white !important; color: #fff !important; font-family: Tahoma, Calibri, sans-serif !important; background-image: url("data:image/png;base64, iVBORw0KGgoAAAANSUhEUgAAABQAAAAUCAYAAACNiR0NAAAABGdBTUEAAK/INwWK6QAAABh0RVh0U29 mdHdhcmUAUGFpbnQuTkVUIHYzLjA4ZXKc4QAAAC9JREFUOE9j5LcMWsxATQAykJqYgZqGgX07aiDFET QahpQn8tEwHA1DMsrKwZ9sADuo19oANiVcAAAAAElFTkSuQmCC") !important }

    So what is the problem with those lines?
  • The line breaks. It needs to be this:

    /* Translucent dialogs (too dark for vistaglazz toolbars) */ @-moz-document url(chrome://global/content/commonDialog.xul) { dialog { background: url("data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAABQAAAAUCAYAAACNiR0NAAAABGdBTUEAAK/INwWK6QAAABh0RVh0U29mdHdhcmUAUGFpbnQuTkVUIHYzLjA4ZXKc4QAAAC9JREFUOE9j5LcMWsxATQAykJqYgZqGgX07aiDFETQahpQn8tEwHA1DMsrKwZ9sADuo19oANiVcAAAAAElFTkSuQmCC") !important } description, checkbox { color: white !important; font-family: Tahoma, Calibri, sans-serif !important; font-size: 11pt !important } vbox > description { font-weight: bold !important } }
    /* Transparent tooltip */ tooltip { -moz-appearance: none !important; background-color: white !important; color: #fff !important; font-family: Tahoma, Calibri, sans-serif !important; background-image: url("data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAABQAAAAUCAYAAACNiR0NAAAABGdBTUEAAK/INwWK6QAAABh0RVh0U29mdHdhcmUAUGFpbnQuTkVUIHYzLjA4ZXKc4QAAAC9JREFUOE9j5LcMWsxATQAykJqYgZqGgX07aiDFETQahpQn8tEwHA1DMsrKwZ9sADuo19oANiVcAAAAAElFTkSuQmCC") !important }
  • That did it.

    Thank you so much for your help Jason.
Sign In or Register to comment.