A fix for wordpress (theobamadiary.com) comment box color change in firefox

amkamk
edited March 2012 in userstyles.org
Install Stylish 1.2.6 Addon for firefox.

Enable the Add-on bar (right click the Menu bar on the top and click the Add-on bar, which will appear at the bottom)

Click the Stylish button at the bottom left corner.

Click the Write new style for theobamadiary.com.

Paste the fix given below. Give a name to the fix. Preview to see if it is ok. Save the style.


@namespace url(http://www.w3.org/1999/xhtml);
@-moz-document domain("theobamadiary.com")
{textarea#comment {background-color: grey !important; color:white !important;}
}

Comments

  • edited March 2012
    It appears you are missing the opening brace for the domain declaration:

    @namespace url(http://www.w3.org/1999/xhtml);
    @-moz-document domain("theobamadiary.com") {
    textarea#comment {background-color: grey !important; color:white !important;}
    }

    EDIT: Never mind - I see you have it preceding the next line.
  • Thanks mikedl. Are you by any chance MB of BJ ? If yes, thank you for your tips that enabled this style.
  • Thanks for overlooking my earlier error.

    Nah, I'm not the person to whom you refer but, one day, I hope I can be as helpful as that. :)

    Still, your code does, indeed, fix the too-dark background in the textarea for commenting and makes it easier to type a response whilst seeing what one has typed.
  • Glad it helped. You can play around with all sortsa colors for the background and text.

    I learnt a little bit about CSS during this exercise. :)
  • I posted the ready-to-use fix here.

    http://userstyles.org/styles/63309/theobamadiary-customize-your-comment-box?r=1333113076

    Just click the green "Install with Stylish" button.
Sign In or Register to comment.