Stylish-Custom

1235781

Comments

  • Stylish-Custom-0.1.6.xpi
    added an enabled row to export styles
    added save/disable to import/export paths
    select all for import/export
    changed import/export save buttons to say import/export instead
    fixed size limit bug for import (10MB instead of 8KB)


    @makondo
    3. look in the skin folder it has the css i used for the stripes
    4. overwrite old files (i had a little bug in it the location should be fine now)

    @your edit: it's for each style not in total
  • edited October 2016
    10 MB per style?!?...

    I did look at the css but couldn't figure what i need (want?) to do there. It's all right, i'll get it. I'm multitasking right now and this can definitely wait ;-)

    Thanks ChoGGi, the new version sounds good, off to get it (Izzy will be in another slight shock when he sees this thread ;-)
  • Posted By: makondo10 MB per style?!?.../home/leaving?target=http%3A%2F%2Fplanetsmilies.net%2Fshocked-smiley-9457.gif
    some people like base64, at least i won't need to change it for awhile :)
  • edited May 2009
    ^ right! ;-)
    OK, i'm stuck with the latest:
    1. What Save and Disable suppose to be/do again? They do nothing here, don't even get checked. Yes, i see the tooltip, just wonder why i can't put a check there.
    Also, eventually, would be nice to have the browse folder dialog there. I understand right now we have to put the path manually, right?
    2. Select All needs ... Unselect All ;-) (of course, i can re-open the window too).

    And about exporting/replace - does it replace styles in the location folder and/or in stylish? I guess it's a '2-folded' question. First: does it replace saved styles in the location folder. And second: does it replace styles on import in the stylish?

    Oh, and i think simple checkmarks instead of icons in the export window will look less busy and cleaner. This is one thing i was looking to change there but need the path @ not to screw all other treechildren ;-)

    TIA!
  • 1. just how it is, you want some feedback instead?
    yeah i'll probably add one
    2. that was my idea or i could have select all toggle

    if you export a file and the old file has the same name it overwrites it
    if you import a style with the same name it makes a new style (i'll see about overwriting it)
    Oh, and i think simple checkmarks instead of icons in the export window will look less busy and cleaner. This is one thing i was looking to change there but need the path @ not to screw all other treechildren ;-)
    i kinda like them :)
    chrome://stylish-custom/content/export.xul / chrome://stylish-custom/content/import.xul


    also i did my part to make firefox suck up ram with that 10MB buffer, i changed it to get the file size and use that
  • Stylish-Custom-0.1.7.xpi
    reduced import buffer size to the size of the file being imported
  • edited May 2009
    chrome://stylish-custom/content/export.xul / chrome://stylish-custom/content/import.xul

    ^ those didn't work got an error for @chrome://stylish-custom/content/export.xul

    I have nothing against the icons but i have this brass/glass style going and want to make that window fit with my sidebar/stylish style.
    BTW, can't get a ...row:hover effect either.
  • see how this works@namespace url(http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul); @-moz-document url(chrome://stylish-custom/content/import.xul),url(chrome://stylish-custom/content/export.xul){ treechildren::-moz-tree-checkbox{list-style-image:url("unchecked.png")!important} treechildren::-moz-tree-checkbox(checked){list-style-image:url("checked.png")!important} }
    it's a tree so :hover won't work. look at the tree hover stuff here
  • edited May 2009
    how about option to disable update checks on certain styles?
    base64 FTW BTW! :)
  • Posted By: makondoIzzy will be in another slight shock when he sees this thread ;-)
    Don't worry. I saw ChoGGi is setting off an avalanche, so I went hiding to not get buried by it. As usual with this kind of natural phenomenon, one waits until it has calmed down. So I'll probably update tomorrow LOL
    Posted By: purplerhow about option to disable update checks on certain styles?
    +1^^ Would help to prevent accidental updates for modified styles, I'm with purpler! Though I guess this would rather be Jasons part - this one had to go to the core.
  • There's a hidden textbox on the edit page for the update URL. Its ID is #update-url.
  • @Jason: If you want to indicate that the URL could be emptied - well, yes, somehow this prevents updates. But has the ugly side-effect that it also eliminates the possibility of opening the scripts homepage from the editor, right? So this means robbing Peter to pay Paul - you get one feature by losing the other. I'd prefer to have an additional (boolean) option here - and I guess the others (especially purpler who brought this up) will agree.

    But thank you anyhow for mentioning that hidden textbox - could be useful for some other feature...
  • edited May 2009
    s to unhide it i guess its enough to add:
    @namespace url(http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul); @-moz-document url-prefix(chrome://stylish){ #update-url {display:inherit!important;} }
    ..to existing Stylish or brand new style..

    so to disable update is it enough to delete the link from textbox?

    also,
    I'd prefer to have an additional (boolean) option here - and I guess the others (especially purpler who brought this up) will agree.

    agree
  • The update URL is separate from the home page URL.
  • edited May 2009
    the Page button of updateless style opens http://userstyles.org/styles/new :\

    also, for sake of faster and better communication it would be better for us to open a IRC channel..
    i could do it if people agree..
  • needs an update for stylish 1.0.2... not seeing the new style textbox with stylish-custom 0.1.7 enabled.
  • Rexel, check my second post above..
  • disabled stylish custom.. restart... make new style with
    "@namespace url(http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul);
    @-moz-document url-prefix(chrome://stylish){
    #update-url {display:inherit!important;}
    }"

    ... enabled stylish custom... restart

    same problem textbox still greyed out/missing.. what did you want me to check again?
  • open some style and you should see URL textbox in bottom part of the style window..
  • Posted By: Jason Barnabe (np)The update URL is separate from the home page URL.
    OK - so it's not as hard as I initially thought. Though: If I only want to disable updates temporarily, e.g. since I'm reworking some style? Sure one could cut and paste the URL into some comment inside the style, but there it could accidentally get lost during other copy/cut-paste actions. Still prefer the boolean. It's just a simple checkbox and one more "if" statement before actually performing updates (or rather checking for updates), right? So it wouldn't mean to much work?
  • 1.0.2 will only mark something as needing an update if it's changed on the server now, so is it still a problem?
  • Basically this solves the issue for "work in progress" styles. So it lowers the priority. Problem still persists if you, for some reason, want to stay with a certain version - e.g. since a newer version was reported to break something, and you want to wait until that's fixed. But I agree if you say that's a rather rare case.

    As for me, this lowers priority from "very, very nice to have" to "nice to have, though" Cool

    But anyway: Thank you very much, Jason - that change was really more urgent than the checkbox LOL
  • i'm keeping Stylish Crack :) on whatever version is on amo, but i'll go do something for 1.0.2b

    btw always remember to ween off the crack habit for new versions before complaining to np
  • edited May 2009
    CHoGGi, there's something else i found - when opening the export window, not all of my enabled styles are shown as such, only a portion of them is 'checked' in the right column as Enabled.

    Oh, almost forgot - thanks for the code above and the links, hover is working fine here, thanks a lot!
  • Another thing is it's difficult to style that window (i know, who will anyway!) - the changes don't apply. You have to close the E/I window then re-open to see changes. Sometimes even that doesn't work. So, you edit the style, then open the E/I window.
    Not a problem, as i said, who will bother?!
    BTW, what are you doing up? I thought you're still sleeping ... isn't it like in the middle of the night there?
  • OK. One more thing - not only styles are not alphabetized, they are also not shown correctly as enabled/disabled. The ones i have enabled show as disabled, and vice versa.
  • edited May 2009
    Stylish-Custom-0.1.8.xpi
    support for Stylish 1.0.2b
    checkbox to choose if a style should be enabled for import
    added browse button to import/export
    update check toggle to edit dialog (need to save to have effect when updating)
    Posted By: makondoBTW, what are you doing up? I thought you're still sleeping ... isn't it like in the middle of the night there?
    :) i'm in est, but i usually work in the evenings
    when opening the export window, not all of my enabled styles are shown as such
    seems fine here
  • edited May 2009
    Ooops then! It appears to be my style, do you mind look and see what i've goofed there? TIA!
    And, i didn't get this one: "... checkbox to choose if a style should be enabled for import (need to save to have effect when updating)..."
  • Posted By: makondoOoops then! It appears to be my style, do you mind look and see what i've goofed there? TIA!
    send me a copy of your stylish.sqlite and i'll take a look at it later on (choggi@gmail.com)

    i added an enable thing to the import dialog if you uncheck it, the style will be imported as disabled (i messed up the changelog a bit)
  • Fixed! working all right now, thank you!
Sign In or Register to comment.