hover over does not reveal exit button

About: Firefox Combine Tab Icon and Tab Close Button
edited May 2011 in Style Reviews
when there are too many tabs this happens.
image
however when there aren't that many tabs, it works fine
image
1024 x 59 - 14K
1024 x 68 - 13K

Comments

  • I am almost certain I had the same problem. It has to do with a tab size setting. Read this and see if it works things out.
  • Should've been more clear. The problem is that when there are too many tabs, hovering over a tab will make the favicon disappear and no exit button will appear. In the second image, there aren't that many tabs, and hovering over the tab will work fine.
  • try this:

    replace:
    /* hide tab close button */ tab .tab-close-button { visibility: collapse !important; } /* display close tab button on tab hover */ tab:not([pinned]):hover .tab-close-button { visibility: visible !important; margin-right:3px !important; }

    with this:
    /* hide tab close button */ tab .tab-close-button { display: none !important; } /* display close tab button on tab hover */ tab:not([pinned]):hover .tab-close-button { display: -moz-box !important; margin-right:3px !important; }
  • Thanks so much! That worked wonderfully =)
  • edited May 2011
    np :)

  • I was going to comment this, and the solution I found was adding this simple line:

    .tabs-closebutton-box, .tab-close-button {display: -moz-box !important}
  • edited September 2011
    Updated 09-06-2011
    Fix some issues with [Ext] Tab Mix Plus Lock, Protect, Auto Reload Icons on Tabs and the issue of the 'Close Tab button' not always appearing when hovered.

    Give it a test to see if there any additional problems that I'm not seeing or I'm not aware of...
  • @rob64rock - Problem still here.

    Free Image Hosting at www.ImageShack.us

    Firefox 6.0.2 on Windows XP
  • edited September 2011
    RNiK said: @rob64rock - Problem still here.

    Free Image Hosting at www.ImageShack.us

    Firefox 6.0.2 on Windows XP
    Did you try testing the latest style update on a fresh Fx profile with only Stylish installed to see if the problem you experienced still occurred?

    I have thoroughly tested latest style update on WinXP Fx 6.0.2, latest Fx7beta, Fx(Aurora)8.0a2 and Fx(Nightly)9.0a1 with a single and multiple tabs(even in Tab overflow mode) and I'm still not experiencing what 'boogerlad' originally reported now or then. You may need test to see if one of your extensions, themes or other CSS styles may be causing the problem.

    On occasion I would experience the problem of single tab doing that, but closing(right-click) then 'undo closing of tab' would then cause the close button to appear again on hover. That's why on the latest style update I added this CSS code:

    .tabbrowser-tab:not([pinned]):hover .tab-close-button {
    display: -moz-box !important; margin-right:3px !important;
    }
    .tabbrowser-tab:not([pinned]):hover .tab-close-button.always-left {
    display: -moz-box !important; margin-right:3px !important;
    }
    .tabbrowser-tab:not([pinned]):hover .tab-close-button.always-right {
    display: none !important;
    }

    In the testing I have done with the newly added CSS code above 'with' or 'without' TMP installed it works has foxxyn8 fix below does, which is just a modified version of foxxyn8 CSS code for TMP compatibility:

    /* hide tab close button */
    tab .tab-close-button {
    display: none !important;
    }
    /* display close tab button on tab hover */
    tab:not([pinned]):hover .tab-close-button {
    display: -moz-box !important; margin-right:3px !important;
    }

    Note: Make sure about:config pref:
    browser.tabs.closeButtons; is set to 1

  • edited September 2011
    Updated 09-08-2011
    Did some CSS code cleanup and fixed the issue of the 'Close Tab button' not always appearing when tab is hovered in Tabs Overflow Mode. Also Configuring [Ext] Tab Mix Plus settings may not be required for TMP to be compatible with this style anymore.

    Give the latest style update that I just uploaded a try and let me know if you are still experiencing any problems.
  • @rob64rock - With your latest update I have no problems at all: well done!
Sign In or Register to comment.