Problem with stylish: Google Dark Gray theme

edited February 2009 in Stylish
Greetings to everyone at userstyles.

Here's the thing: I installed Stylish yesterday and added the Google Dark Gray redesign theme, which worked perfectly. (I also installed one for youtube and another for wikipedia, but I think that's uninportant...). Everytime I close my browser I use the "clean personal information" window to clean the caché, history and stuff... and today I decided to clean my cookies too. Oh surprise when later I go back to google and the Dark Grey style is gone!! Even when it was checked and enabled in the stylish window, and supposed to be working.

I tried deleting the theme and re-installing it, and then uninstalling and re-installing Stylish in firefox. None of it has worked to make the theme work (I didn't tried to reinstall firefox, though)...

That Dark theme is... awesome in several ways, and I really want it back... so please, any help on this issue would be very appreciated ^^

Comments

  • edited February 2009
    Try installing a new theme and applying it then reapplying the dark theme
  • Thanks Maikeru. I tried to do that, but... for some reason it is not working... I think it may have something to do with the code of the style, because neither the Gray or Dark Blue themes will work, but some others like "Darkoogle red" do work. A small difference I can see in the code of these styles is in the "url-prefix" lines:

    Gray and Blue start with the same lines( ...url(http://www.google.com/), url-prefix(http://www.google.com/webhp),url-prefix(http://www.google.com/search?), ... )

    whether Darkoogle red starts with something like: ( ... url-prefix(http://www.google.),url-prefix(http://images.google.)... ).

    I don't fully understand how this work, or if this difference has anything to do with my issue... but if it does, maybe it can give a clue of why is that happening. Or maybe something changed in the code of google.com which is "unabling" or goes into conflict with the code of the Dark and Blue styles?? I can't really tell (until I learn web programming...), but if some of you do... then please help!!! =(

    Les agradezco mucho su ayuda ^^
  • i'd guess your cookies were setup to use google.com, but after you cleared the google cookies it redirects to google.es or wherever
    go here it should disable the country redirect and just take to you .com
    or you could use the url-prefix from the working one on the non-working one
  • PERFECTO!! It worked like a charm!
    Thank you very much Mr. ChoGGi. Now I'm happy again ^^
Sign In or Register to comment.