Chrome Skin

About: Chrome Skin


  • I've checked on another computer - the same problem. The close button disappeared for faviconized tabs.
  • And yet another check under Linux showed that there is the same problem there: close button disappeared from faviconized tabs.
  • Here is an example that illustrates the problem I reported before.
    Free Image Hosting at
  • Thx for the screenshot ;) I will check that as faster as i can.
  • no problem.
    it looks like a right side of faviconized tab has transparent color or something.
  • I was thinking about
    - a missing " { display: block !important; }" i removed for "TMP" compatibility.
    - or something else that i'll see later.

    You can try the first solution, or thx to be patient ;)
  • edited April 2009
    Oh! you mean to try it and insert it into your code...
    Well, I tried it and it worked!


    I just want to clarify that the problem is with faviconized tabs only. So, maybe you can specify something like:tab[faviconzed="true"] { display: block !important; }
  • Good (yes that's what i meant :)

    I'll put it back in the code while i locally make a compatibility with "TMP".
  • You'd better use: .tabbrowser-tabs tab[faviconized="true"] { display: block !important; }
  • edited April 2009
    Calling tab after .tabbrowser-tabs seems to be a mistake, not ? (these classes point the same element)

    I make a mistake :
    .tabbrowser-tab[faviconzed="true"] { display: block !important; }

    I correct now with :
    .tabbrowser-tab[faviconized="true"] { display: block !important; }
  • Great - it is fixed now !
  • edited April 2009
    I just want to verify that Hide Chrome style works perfectly under Linux.
    My previous report about it not working under Linux was false due to Hide Chrome style being not installed there ;)
  • Take a look at dots (...) - if there are a lot of tabs then they (dots) go over the next tab:
    Image Hosted by
  • Also, under Linux Firefox's has Preferences under Edit menu. Therefore, under Linux in order to change Firefox options user will have to un-apply your style first.
  • edited April 2009
    (i'm hesitating to include "chrome skin plus hide chrome" directly in the main style)

    For the tabs, their close buttons are not hidden with me (even if one billion tabs), that's a problem i had and i haven't got it since few monthes. So that's not normal for you :s

    I don't understand your last post. What this preference menu is ? (the toolsmenu options ?)
    (edit menu is hidden in "popups [...] cleaner")
  • edited April 2009
    1. I'm not talking about integrating "Hide Chrome style" into the "Chrome Skin". I just said that it is working under Linux.
    2. I do not understand why you do not have close buttons hidden if you do have a lot of tabs. The screenshot I posted before was from Windows XP. I've tested right now under Linux (Fedora 10) and got the same result.
    It is regular Firefox behaviour to hide close buttons of inactive tabs.
    3. Under Linux there is no Options menu like in Windows (Tools->Options). Instead, there is Preferences menu under Edit menu:...... or, well, here is a screenshot:
    Image Hosted by
  • Interesting article about Firefox themes: IS HERE
    I've uploaded classic.jar extracted in a way described in the article above and you can download it here
  • Yet another bug report:
    Image Hosted by
    This is the right side of tab loaded in background (right-click any link and choose "Open Link in New Tab")
  • - I fixed this last tab.

    - Your article is interesting and simple ! I can try to make a "Tango theme" addon know to verify what's wrong on Linux. Thx :)

    - I don't hide the edit button in Chrome Skin, you know, it is hidden in "Popups[...] Cleaner". Just open this style and remove the #edit-menu line.

    - I understand about the "Hide Chrome" style and the buttons. If it's ok, that's good so ;)

    - About the hidden tabs close buttons, i'll chek without my different styles, and see if i have your problem.

  • Yes, you do hide "Edit" menu. This is what I have found in your code:

    /* --- main menu buttons --- */ #menubar-items #edit-menu, #menubar-items #helpMenu { display: none !important; }
  • edited April 2009
    Oups, sorry, you're right ^^' I forgot that. (fixed)
  • Neiimad, in your description to the Chrome Skin style you say:
    Any styles / extensions can be incompatible with this skin. If you encounter any problems you can do a report following the link at the end of this page.
    You should say:
    Any style / extension can be incompatible with this skin. If you encounter any problem you can report it following the link at the bottom of this page.
    You also should write which instead of wich.

    Well, this is just to make description well-written :)
  • edited April 2009
    Thx for the suggestion. I searched the real way i wanted to explain myself, and i replace "any" with "some".
  • edited April 2009
    I've tested "Chrome Skin" on Fedora more carefully.
    If user does not change the skin to something Strata-like - your style inded does not work (left and right edges of tab are not styled).
    If Strata Aero theme is applied - almost everything is good.... Except that in "Preferences" ("Options") menu each dropdown malfunctions... screenshot :

    Image Hosted by
  • Another idea:
    if you take a close look at the screenshot above you will see that buttons are very well done, they are very 3d-like.
    And their behavior is the following:
    1. When inactive (not hovered, not pressed) the background - the background is almost like yours, BUT lighter: the gradient is not so huge.
    2. When button is hovered the background disappears and background color = color at top of the button.
    3. When item is pressed its background is changed to gray (like your hover effect) PLUS its text and icon are displaced to the right and bottom by 1px.
    I will post screenshots tomorrow.
  • edited May 2009
    If you want to check all the Linux problems yourself - you can use VirtualBox (it is free) and install Fedora.

    VirtualBox: HERE
  • I know VirtualBox (nLite rulez, or to test a Linux platform), and that's right that could be more simple. Why i didn't think about that before oO

    I'll reinstall it to make the tests.
  • How to get my tabs on top of address bar instead of below? With another style? And, if I do it with another style it looks like this:

    Image and video hosting by TinyPic

    Why are they upside-down, and not like in your screenshot?
  • edited May 2009
    To Angel: I believe Neiimad didn't change the screenshot yet.

    To Neiimad: Indeed, it looks like you didn't change the screenshot :). Another thing - new Firefox 3.5 (aka 3.1) has "New Tab" button. Maybe you should style it the way you did before.
Sign In or Register to comment.