Stylish crashes Firefox 3.6

edited January 2010 in Stylish
On Mac OS X (10.6), Firefox 3.6 will not start with the Stylish extension (it crashes before it opens a browser window). Uninstalling/reinstalling Firefox, deleting Firefox profiles, creating new profiles, nothing stops it. Other user accounts on the same computer are totally fine (they start with Stylish enabled without problems).

Any ideas? Does Stylish store settings somewhere that could be corrupted for only my account and that aren't in the profile folder?



  • The same happens to me as well.
    Firefox 3.6, Windows 7

    I am using roaming profiles - so it's the same user profile on all machines. I am roaming between two machines and on both Firefox crashes when I visit a page for which there is a custom style defined. When I disable Stylish it does not crash any more.
  • Is it any style that's doing this, or just specific ones?
  • It's hard to say, because I can't figure out if it's trying to load any files (Firefox crashes way before I could get to the Stylish menu). I tried deleting the extensions folder for stylish, which I think should have removed the styles, but it's hard to tell.
  • For me FF 3.6 just crashes when I surf to a page for which I've defined a specific style. Pages for which there is no custom style do not crash FF. For me I just have styles for two sites defined and on both of them FF 3.6 crashes as soon as I enter the URL and press enter.
  • @skybeam, can you post links to the styles that are crashing your browser? I'd like to install them on my rig and see if my browser crashes, just for confirmation since I'm running Win 7 (x64) too.

    Currently I've been running the FF 3.6 with Stylish 1.0.8 and haven't experienced any problems, though I only have one browser theme style installed.

    I've been experiencing major crashes with FF 3.5 and 3.6, which I've concluded that its the LastPass extension being the culprit. Currently I have LastPass disabled and haven't experienced any crashes. Thought I'd put that out there in case anyone experiencing crashes may want to check and see if they have LastPass installed, and check to see if its causing a problem.
  • As I wrote I am only using Stalisch for two sites: and The styles I am using:

    However I just noticed that my styles were not updated so I did an update now and guess what - it's not crashing any more :-o

    I am not using an extension called LasPass.
    I am running Stylish v.1.0.7.
  • I have the same results as jscushman on Linux (x86_64), (firefox crashes before it opens a browser window). This occurs even on new profiles with no styles. I don't know if this is the same problem for jscushman but it seems to happen only when I use a symbolic links (.mozilla -> local/conf/firefox) in the path for my firefox profile. This was not a problem till I updated to Firefox 3.6 iirc. This appears to affect both Stylish and another extension FireGestures. Don't know if this is a firefox problem or a extension problem but it would be nice to have it work again as I use these symbolic links to make backing stuff up simpler.

    Note/strange work around: If I attempt to load up firefox in safe mode but quit out when it asks what changes I want to make (disable add-ons, reset stuff,...) and then try to start firefox normally it starts up once, with all my plugins working, until I repeat this.
  • Browser doesn't not start at all with Stylish 1.0.8 turned on. After disabling the extension it starts and work normally. With extension browser starts only after single safe-mode session.
    When start check what is diffrent, i found that the diffrence (that have influence on firefox crash ) was in the LastVersion field After setting this field to "Safe Mode" browser works great.

    --- a/7x6a8356.kvark/compatibility.ini Fri Apr 30 23:55:07 2010 +0400
    +++ b/7x6a8356.kvark/compatibility.ini Sat May 01 00:00:26 2010 +0400
    @@ -1,5 +1,5 @@
    -LastVersion=Safe Mode

    I use firefox from〈=ru Test on clean profile, no other plugins installed.
  • You can start Firefox with the flag -stylish-disable, which will make Stylish active but make it not apply any styles. Then you can disable all your styles and restart normally. If that works, it's one of your styles that's doing it.
  • Posted By: Jason Barnabe (np)You can start Firefox with the flag -stylish-disable, which will make Stylish active but make it not apply any styles. Then you can disable all your styles and restart normally. If that works, it's one of your styles that's doing it.
    It was clean profile without any user styles. I just install extension in browser. To check LastVersion field dependance i create new profile/
Sign In or Register to comment.