Styles not loading by default

edited April 2007 in Stylish
I am trying to eliminate the fixed footer on gubb.net. I set this style:

@-moz-document domain("gubb.net") {
#footer {
position:relative;
background: #3366FF url("http://gubb.net/images/bg_content.gif") repeat-y top left;
}
}

Problem 1: When gubb.net loads, Stylish shows that user style as active, but it is not applied. I have to disable and re-enable the style for it to work.

Problem 2: After Stylish does apply the style, it does not apply the background image (or color). Of note, however, is if I right click in the footer and go "View Background Image" it displays the background image in question ("bg_content.gif" above).

Any ideas? My only thought on problem 1 is gubb.net is doing a lot of javascript foo. Could it be applying styles _after_ Stylish (this seems unlikely but I don't know the order of execution)? As for problem 2, I haven't a clue.

Thanks!

Comments

  • @-moz-document domain("gubb.net") {
    #footer {
    position:relative !important;
    background: #3366FF url("http://gubb.net/images/bg_content.gif") repeat-y top left !important;
    }
    }
  • Ah yes the all important !important flag. This worked as far as getting the style to load right away, but I still can't figure the background, #footer is still backgroundless, even though firefox will do a "view background image" to the image in question.
  • this work?
    @-moz-document domain("gubb.net") { #footer { position:relative !important; background: url("http://gubb.net/images/bg_content.gif") repeat-x top left !important; } }
  • The position has always worked (!important makes it apply immediately). The background still refuses to show either color or image.
Sign In or Register to comment.