Request: Quick search (ctrl+F) function.

edited June 2008 in Stylish
Request: Quick search (ctrl+F) function in a window with a style.
«13456

Comments

  • edited May 2009
  • edited June 2008
    Quote: Bucket on this fileTHE BEST THE BEST THE BEST THE BEST THE BEST THE BEST THE BEST THE BEST THE BEST THE BEST THE BEST THE BEST
    This simplifies style editing a lot.
  • edited July 2008
    ignore this msg
  • Posted By: ChoGGithis?
    Thx alot. Why it's still not implemented in a normal package?
  • it just isnt :)
  • How does this work?
  • it adds a search box to the edit style dialog
    ctrl+f sends focus to it, f3 is find next
  • Thanks! Now, what do i do with it? It's a 7z file, i read the readme in one folder.... I just don't get it. Could you give me steps, please?
  • With Firefox closed.
    1. Un-zip the files.
    2. Find and copy "edit-mikado.xul"
    3. In your profile folder find "...\extensions\{46551EC9-40F0-4e47-8E18-8E5CF550CFB8}\chrome\content". Paste "edit-mikado.xul" here.
    4. In the "content" folder find "edit.xul" and delete. Rename "edit-mikado.xul" to "edit.xul".
    5. Close profile folder. Restart Firefox.
  • Ooooh! This is good, thanks guys! jw25 - thanks a lot!
  • I have a problem. There has to be something in that file about the !important - ever since i installed it, every time i press ! while editing a style, it will paste '!important;important' and it jumps to the top of the page. I now copy/paste that part (!important;) from some other line to avoid pressing ! or i'll have to scroll to find the line i was editing and then delete the extra important. Any ideas?
    TIA!
  • edited September 2008
    forgot i added that :)
    in edit.xul look for
  • edited September 2008
    That was it, thanks ChoGGi! I like it though, if only it'd work right for me (i mean the !important; part).
  • edited February 2009
    dammit, i've changed something, now it doesn't paste "!important;" when I click "!"
    how to bring it back? :(
  • you need to open edit.xul in notepad or something find that line mentioned above then just below that line there's another one starting with onkeypress, remove that line
    or download it here
  • oooh, thx for sooo fast answer!
    sry, my problem is a little bit changed, so, I will write it once again:
    i've changed something, now it doesn't paste "!important;" when I click "!"
    how to bring it back? :(
  • download this
    then copy edit-Mikado.xul to "firefox profile"&#0092extensions&#0092{46551EC9-40F0-4e47-8E18-8E5CF550CFB8}&#0092chrome&#0092content&#0092edit.xul
    or just reinstall the xpi in the easy method folder
  • edited February 2009
    done, but it still doesn't work for me. When I click "!" it just types "!", instead of "!important;"

    oh, wait... I just needed to re run FF, now it works... thanx, Choggi
  • Is there a new edit.xul for the latest version of Stylish? This file doesn't appear to work with the new version.
  • i haven't gotten around to it yet
  • i updated it for v1.0 (same link as above)

    i also added a couple buttons
    one opens the error console (press clear to remove everything else then press preview in stylish, it'll show any errors and the line number)
    the other toggles the tag area (i also made it hidden by default)
  • edited May 2009
    you are in a quite short contact with Jason, why it is still not implemented into official version? Did you offer it to him? What did he answer?
  • the search function? he isn't planning on adding it
  • Man! It screwed my install, hafta reinstall 1.0. Thanks, ChoGGI! ;-)
    Clicking on Edit brought up ... a horizontal scrollbar!... ;-)
    Don't worry, i'll get it ... eventually.
  • you tried easy install.xpi?
  • Yeah, i gotit. Thanks a lot, looks awesome!
  • edited May 2009
    ChoGGi,
    i don't use tags but when i clicked it (out of curiosity ;-), nothing happen. Here's the error:

    Error: ToggleTagsArea is not defined
    Source file: chrome://stylish/content/edit.xul
    Line: 1
    ================

    And, just like back on Sep.6th of the last year (see above), it again puts 'important;' to every line as soon as you hit !
  • edited May 2009
    did you remove Mikado.js or remove this line from edit.xul?
    &#60script type="application/javascript" src="Mikado.js"/&#62
    if not then what version of ff and what os are you using?

    check the readme to remove !important

    edit:added some code that sticks some values in the toggle button (if the tag area is showing and what it contains)
  • NM, ChoGGi, reinstalled and it's working all right. I don't use tags, so it's not an issue for me, just a dead button, no biggie. Thank you!
  • :) i don't either, just assumed some people do so
Sign In or Register to comment.