Stylish 0.5a and Thunderbird

edited March 2007 in Stylish
I just installed Thunderbird 2 (Beta 2) and thought I'd try Stylish out with Thunderbird. I used the 0.5a dev version of the extension and managed to get it working after a slight modification to mailOverlay.xul.

Jason: I'm guessing that your development version has changed quite a bit since you release the alpha but I thought Thunderbird deserved it's own thread. Feel free to tell me to merge this discussion with the other thread (and sink this thread :) )

The main issues I had were with the doctype of the overlay and the xul for the popup.

1) the dtd that is specified in mailOverlay.xul doesn't exist
2) the branding.dtd isn't included which means the &stylish; entity is undefined. This was the main problem with getting it to run at all.
3) <script type="application/javascript" src="seamonkeyCompat.js"/> gives an error:
Error: missing ; before statement Source File: chrome://stylish/content/seamonkeyCompat.js Line: 1, Column: 19 Source Code: var seamonkeyCompat() { I just ignored this.
4) Clicking on the Stylish icon resulted in a blank popup and gave the following error:
Error: uncaught exception: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIStringBundle.GetStringFromName]" nsresult: "0x80004005 (NS_ERROR_FAILURE)" location: "JS frame :: XStringBundle :: getString :: line 17" data: no]Dismissing the popup gave
Error: stylishCommon.popupHiding is not a function Source File: chrome://messenger/content/messenger.xul Line: 1I poked around with DOMi a bit but really, my understanding of xul and extensions isn't up to working out what does what and where the strings are supposed to come from, etc.
Middle clicking still gave the Manage Styles window.
5) The edit dialog not appearing when opened for the second time bug was present. As expected.

A simple style I tried worked (see Spell Checking) but I haven't heavily tested functionality.

Looking forward to the second alpha.

Wildmyron

Comments

  • Yes, it all works in the second alpha already. I'm just working on getting SeaMonkey going before I make it public.
Sign In or Register to comment.