Notice: The devs are no longer actively involved in the forum, so any bug reports regarding the Stylish extension or this website should be sent to them directly at contact@userstyles.org.

Spell checking proposals in Thunderbird

edited March 2007 in userstyles.org
Spell checking proposals are shown in Firefox context menu in bold characters. This is very convenient and easy to find even with large context menus.

In Thunderbird it's less convenient because of proposals in standard characters. Is there any chance to change the characters to bold?

Joke

Comments

  • menuitem[oncommand="InlineSpellChecker.selectSuggestion(event.target.value, null, null);"] { font-weight: bold; }
  • Thank you for the code and sorry for my late answer.

    I tried the code, but it didn't work. Possible, that it works only with Thunderbird 1.5.0.x? I tried it with Thunderbird 2.0beta2.

    Joke
  • Hmm, I don't have a copy of Tb2 to test but looking at lxr you might need to change [oncommand="InlineSpellChecker.selectSuggestion(event.target.value, null, null);"] to [oncommand^="InlineSpellCheckerUI.replaceMisspelling("]
  • Thank you so much for your efforts - but I'm sorry, it still won't work.

    Joke
  • In that case you'll have to grab the DOM Inspector (unfortunately Windows only currently, the OS X and Linux versions haven't been updated yet) yourself and find it. To do so make a new message, type some nonsense and right-click it to populate the context menu. Then open DOM Inspector from the Tools menu of the main Thunderbird window, inspect the Compose window and search for the id "spellCheckNoSuggestions". Above it should be the suggestion menuitems which should all have identical oncommand attributes
  • edited March 2007
    The selector in comment 2 should work. I just installed Thunderbird 2 Beta 2 and installed the DOMi for it. The oncommand node for the spelling suggestions is indeed InlineSpellChecker.selectSuggestion(event.target.value, null, null);

    With a bit of wrangling I also managed to get Stylish working and the following style worked for me:
    @namespace url(http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul); menuitem[oncommand^="InlineSpellChecker.selectSuggestion("] { font-weight: bold !important; }
    I did have to restart Thunderbird to get it to work though. When I poked at the CSS Style Rules with DOMi, the important flag wasn't set for some reason. On second thought I'm not sure if this was because I edited the style to include !important and it didn't update properly.

    Edit: btw, this should probably be in the Style Requests Category.
  • Oh I really enjoy it - it works!

    @ Kwan + Wildmyron:

    Thank you for your help to get this little bit more of life quality!

    Joke
Sign In or Register to comment.